big sur – Mounting Sparse Bundle on NFS Share

Background

I have a Seagate BlackArmor NAS220 running Debian. I would like to use the NAS as a target for Time Machine backups from my Mac (2020 Mac mini M1). I have used disk utility to create a 500 GB sparse bundle disk image (HFS+J). I can mount the sparse bundle on my computer no problem when it is stored locally. I then copy the sparse bundle to my NAS.

Problem

When I try to mount the sparse bundle on my Mac while it is stored on the NAS (by double-clicking on it) I get the following error:

error1

When I double click on it again I get this error:

error2

Attempting to mount via the Terminal using,

sudo hdiutil attach -verbose /path-to-network-share/MacminiTM.sparsebundle/

results in,

Mac-mini:Time Machine Backups christopher$ sudo hdiutil attach -verbose /path-to-network-share/MacminiTM.sparsebundle/
Initializing…
CBSDBackingStore::newProbe directory, not a valid image file.
DIBackingStoreInstantiatorProbe: interface  0, score    -1000, CBSDBackingStore
DIBackingStoreInstantiatorProbe: interface  1, score     1000, CBundleBackingStore
DIBackingStoreInstantiatorProbe: interface  2, score    -1000, CRAMBackingStore
DIBackingStoreInstantiatorProbe: interface  3, score    -1000, CDevBackingStore
DIBackingStoreInstantiatorProbe: interface  4, score    -1000, CCURLBackingStore
DIBackingStoreInstantiatorProbe: interface  5, score    -1000, CVectoredBackingStore
DIBackingStoreInstantiatorProbe: interface  0, score      100, CBSDBackingStore
DIBackingStoreInstantiatorProbe: interface  1, score    -1000, CBundleBackingStore
DIBackingStoreInstantiatorProbe: interface  2, score    -1000, CRAMBackingStore
DIBackingStoreInstantiatorProbe: interface  3, score    -1000, CDevBackingStore
DIBackingStoreInstantiatorProbe: interface  4, score    -1000, CCURLBackingStore
DIBackingStoreInstantiatorProbe: interface  5, score    -1000, CVectoredBackingStore
CBSDBackingStore::newProbe directory, not a valid image file.
DIBackingStoreInstantiatorProbe: interface  0, score    -1000, CBSDBackingStore
DIBackingStoreInstantiatorProbe: interface  1, score     1000, CBundleBackingStore
DIBackingStoreInstantiatorProbe: interface  2, score    -1000, CRAMBackingStore
DIBackingStoreInstantiatorProbe: interface  3, score    -1000, CDevBackingStore
DIBackingStoreInstantiatorProbe: interface  4, score    -1000, CCURLBackingStore
DIBackingStoreInstantiatorProbe: interface  5, score    -1000, CVectoredBackingStore
DIBackingStoreInstantiatorProbe: interface  0, score      100, CBSDBackingStore
DIBackingStoreInstantiatorProbe: interface  1, score    -1000, CBundleBackingStore
DIBackingStoreInstantiatorProbe: interface  2, score    -1000, CRAMBackingStore
DIBackingStoreInstantiatorProbe: interface  3, score    -1000, CDevBackingStore
DIBackingStoreInstantiatorProbe: interface  4, score    -1000, CCURLBackingStore
DIBackingStoreInstantiatorProbe: interface  5, score    -1000, CVectoredBackingStore
Attaching…
Error 5 (Input/output error).
Finishing…
DIHLDiskImageAttach() returned 5
hdiutil: attach failed - Input/output error

I can’t figure out why the sparse bundle mounts fine when it’s stored on my Mac locally, but not when on the network share.