Can not Start LSB: Squid HTTP Proxy Version 3.x

I have a problem where I can not install things with apt-get anymore. I use Kali Linux, I have the new OS, and then installed Squid. This has never worked at all, even when booting the OS it would show that the squid has failed. I did not think about it. I can not use apt-get upgrade or apt-get install anymore. I tried using the service command but I did not work, that was the end result.
beginning of the service squid
The job for squid.service failed because the check process ended with an error code.
See "systemctl status squid.service" and "journalctl -xe" for more details.
————————————————– —————————- Same thing for restarting the service squid.
I do not know if I have it wrongly installed or what, but when I try to use "sudo apt-get upgrade", it spits all that.
sudo apt-get upgrade
Reading package lists … Done
Build a dependency tree
Reading status information … Done
Calculating the upgrade … Done
The following packages have been installed automatically and are no longer needed:
geoip-database-extra libadns1 libct4 libjs-openlayers
linux-image-4.9.0-3-686-python python-adns python-easygui python-levenshtein
python-metaconfig python-prettytable sqsh
Use sudo apt autoremove & # 39; to delete them.
The following packages have been preserved:
libfreerdp-cache1.1 libfreerdp-client1.1 libfreerdp-core1.1
libfreerdp-gdi1.1 linux-image-686-pae mariadb-client-10.1
mariadb-server-10.1 mariadb-server-core-10.1 tshark sonhark-common
filshark-qt
0 upgraded, 0 newly installed, 0 to remove and 11 not upgraded.
1 not completely installed or removed.
After this operation, 0 Bb of additional disk space will be used.
Do you want to continue? [Y/n] there
Setting up the squid (3.5.23-5 + deb9u1) …
Setcap worked! / usr / lib / squid / pinger is not suid!
The job for squid.service failed because the check process ended with an error code.
See "systemctl status squid.service" and "journalctl -xe" for more details.
invoke-rc.d: squid initscript, the action "restart" failed.
● squid.service – LSB: HTTP proxy Squid version 3.x
Loaded: loaded (/etc/init.d/squid; generated; vendor preset: disabled)
Active: failed (result: exit code) since Sat 2019-02-23 22:59:41 PST; 11ms ago
Docs: man: systemd-sysv-generator (8)
Process: 18357 ExecStart = /etc/init.d/squid start (code = left, status = 3)

February 23 22:59:41 Master systemd[1]: Starting LSB: HTTP proxy Squid version 3.x …
February 23 22:59:41 Master squid[18357]: FATAL: redirect_program / root / googlese … led!
February 23 22:59:41 Master systemd[1]: squid.service: closed control process, c … us = 3
February 23 22:59:41 Master systemd[1]: Can not start LSB: Squid HTTP Proxy ve … 3.x.
February 23 22:59:41 Master systemd[1]: squid.service: The unit went into failure state.
February 23 22:59:41 Master systemd[1]: squid.service: Result-Exit-… failed.
Tip: Some lines were ellipsized, use -l to display them in full.
dpkg: error processing package squid (–configure):
the post-installation script installed in the subprocess returned the error status 1
Errors were encountered during treatment:
squid
E: The / usr / bin / dpkg subprocess returned an error code (1)


I do not know what to do, I can not use tools like msfconsole because I can not
update it. I do not know if it should do anything with squid code or what, but if anyone has an idea of ​​how I can fix that error or how it has occurred. tips are helpful

Thank you.