composer problem: drupal / core-recommended 8.8.5 requires composer / installers v1.7.0 -> satisfiable by composer / installers[v1.7.0]


We have Drupal 8.8.5 running on CentOS Linux 7 with PHP 7.1.33.

I was trying to update modules using composer. The composer said they had been updated, but when I entered the program, they weren't. During troubleshooting, I deleted the "supplier" directory. Now I get this error:

(root @ ip-172-31-13-94 master) # composer update – with-dependencies
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your needs could not be resolved in a set of installable packages.

Problem 1
– drupal / core-recommended 8.8.0 requires composer / installers v1.7.0 -> satisfiable by composer / installers (v1.7.0).
– drupal / core-recommended 8.8.0-beta1 requires composer / installers v1.7.0 -> satisfiable by composer / installers (v1.7.0).
– drupal / core-recommended 8.8.0-rc1 requires composer / installers v1.7.0 -> satisfiable by composer / installers (v1.7.0).
– drupal / core-recommended 8.8.1 requires composer / installers v1.7.0 -> satisfiable by composer / installers (v1.7.0).
– drupal / core-recommended 8.8.2 requires composer / installers v1.7.0 -> satisfiable by composer / installers (v1.7.0).
– drupal / core-recommended 8.8.3 requires composer / installers v1.7.0 -> satisfiable by composer / installers (v1.7.0).
– drupal / core-recommended 8.8.4 requires composer / installers v1.7.0 -> satisfiable by composer / installers (v1.7.0).
– drupal / core-recommended 8.8.5 requires composer / installers v1.7.0 -> satisfiable by composer / installers (v1.7.0).
– drupal / core-recommended 8.8.x-dev requires composer / installers v1.7.0 -> satisfiable by composer / installers (v1.7.0).
– drupal / core-recommended 8.9.0-beta1 requires composer / installers v1.7.0 -> satisfiable by composer / installers (v1.7.0).
– drupal / core-recommended 8.9.0-beta2 requires composer / installers v1.7.0 -> satisfiable by composer / installers (v1.7.0).
– drupal / core-recommended 8.9.x-dev requires composer / installers v1.7.0 -> satisfiable by composer / installers (v1.7.0).
– Conclusion: do not install Composer / Installers v1.7.0
– Installation request for drupal / core-recommended ^ 8.8 -> satisfiable by drupal / core-recommended (8.8.0, 8.8.0-beta1, 8.8.0-rc1, 8.8.1, 8.8.2, 8.8 .3, 8.8 .4, 8.8.5, 8.8.x-dev, 8.9.0-beta1, 8.9.0-beta2, 8.9.x-dev).

Can anyone tell us how to fix this problem? Thank you!