Creating an Oracle 11.2 Compatible Database in Oracle 12.2.0.1

I am using an Oracle Docker image of 12.2.0.1 in my development environment:

https://github.com/oracle/docker-images/tree/master/OracleDatabase/SingleInstance/dockerfiles/12.2.0.1

There does not seem to be any equivalent for this for 11.2.0.4. The database where my code will be deployed in production is 11.2.0.4, so I have to work with compatible = 11.2.0.4.

I've tried several times and many ways to set compatible = 11.2.0.4 but I can not get it working. It seems that, anyway, because of the built-in models or anything, I have the feeling that the 12.2 control files are not compatible with 11.2.0.4.

Can I create a CDB or PDB with 11.2.0.4 compatibility with 12.2.0.1? Currently, the question is whether it is even possible or not. If possible, high level advice on how to do it would be much appreciated.