dart – Error en Flutter pub get

Intentando usar firebase_messagig 7.0.3 que es la mas reciente, cuando la agrego ap pubspec.yaml y que se haga el flutter pub get, marca error porque dice que es necesario usar otra version de firebade_core, la version que requiere la inserto también, pero luego dice que otra paquetería no es compatible, que se pudiera hacer, para saber la compatibilidad de los paquetes