Debian 10: The following packages have unmet dependencies

I’m trying to install some software as part of a project I am working on for a client.

The software is an apt/deb package. The downloads page for this package state that it is designed to work with Ubuntu 18.xx / 20.xx.

I tried to install this package from the command line, but this error resulted:

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 fastcinemadng : Depends: cuda-10-1 but it is not installable
                 Depends: libjpeg-turbo8 but it is not installable
E: Unable to correct problems, you have held broken packages.

Is there anything I can do about this or am I essentially in an impossible situation.

Appreciate I should really be using Ubuntu to do this, but I can’t change OS easily as this system is a laptop. If I want to try with a version of Ubuntu, I will have to go and buy a new disk drive.