Google Search Console does not find all sitemaps in the sitemap index. How to fix?


I have created a valid sitemap index (/sitemap-dec2019/sitemap_index.xml) for a site as follows:

    


https://www.example.com/sitemap-dec2019/sitemap1.txt
2019-12-10T18:24:17+00:00


https://www.example.com/sitemap-dec2019/sitemap2.txt
2019-12-10T18:24:17+00:00


https://www.example.com/sitemap-dec2019/sitemap3.txt
2019-12-10T18:24:17+00:00

.
.
.

https://www.example.com/sitemap-dec2019/sitemap536.txt
2019-12-10T18:24:17+00:00


Each child Sitemap is a simple list of 49,999 URLs and their size is less than 10 MB.

I have uploaded the Sitemap index and all the Sitemap children to the server. I double checked to make sure the Sitemap index and all Sitemap children are all accessible on the server, and they are.

However, when I submit the sitemap index to Google via the Google Search Console, I receive a success message saying "Sitemap index processed successfully", no error is reported anywhere, and yet it lists only 9 of the 106 Sitemap children (and they all start with & # 39; sitemap1 & # 39;):

Sitemap                         Status  Discovered URLs
/sitemap-dec2019/sitemap1.txt   Success 49,999
/sitemap-dec2019/sitemap10.txt  Success 49,999
/sitemap-dec2019/sitemap100.txt Success 49,999
/sitemap-dec2019/sitemap101.txt Success 49,999
/sitemap-dec2019/sitemap102.txt Success 49,999
/sitemap-dec2019/sitemap103.txt Success 49,999
/sitemap-dec2019/sitemap104.txt Success 49,999
/sitemap-dec2019/sitemap105.txt Success 49,999
/sitemap-dec2019/sitemap106.txt Success 49,999
1-9 of 9

There is nothing different in the sitemap index that would require Google to select only these 9 children of specific sitemaps.

Under the total number of URLs discovered, it is shown 449,991 which happens to be 49,999 x 9.

When I delete the sitemap and add the sitemap index, the even 9 Sitemap Children are listed and none of the others appear anywhere.

Since there are more than 100 Sitemap children, this means that over 90% are completely ignored.

How can I fix this so that all 100% of the Sitemap children (and their respective URLs) are discovered?