I can’t get Mac keyboard shortcuts to work as designed, if at all

I run into this problem constantly, across all manners of applications, and I’m beginning to think I’m just not doing something correctly.

Basically any and all mac keyboard shortcuts mostly don’t work for me, and the problem is extremely apparent when the keyboard shortcut involves using 2 keys + cmd key.

For example, I am using IntelliJ right now, a java editor. I can use cmd and + to collapse a single function. Cmd, a, and + should collapse all functions. The former works, the latter selects everything and does nothing else. Up + cmd + a is supposed to open the “find action” dialog; instead it opens a random drop down for selecting a file in my project. I’ve tried pressing the keys simultaneously, in all sorts of sequences. Almost every application I touch has this issue. If the 3 key combos do anything, it’s never what they say they’ll do. Snag it screenshots? Nope. Redo action? Nope. You name it, doesn’t work.

Please help. I’m tired of clicking through window options like someone who just took their first course at the library in computer literacy. I used to do literally whatever you could imagine with Windows and barely even need a mouse at all.