javascript – Does not trigger the show.bs.modal event

Do you speak blz?

I have the next stalemate in my project using the event on show.bs.modal button does not trigger the event .. below:

Index:

<? php

header ("Cache-Control: no-cache, must-revalidate");
header ("Expires on Saturday, July 26, 1997 at 05:00:00 GMT");

require_once ("authenticate.php");

login ();

$ user = wp_get_current_user ();

require_once & # 39; cfg.php & # 39 ;;
require_once & # 39; functions.php & # 39 ;;
require_once DBAPI;
$ db = open_database ();

index ();

include (HEADER_TEMPLATE);

if ($ db):?>

The users

<div class = "alert alert- alert-licenciable "role =" alert ">

E-mail key The options
btn-sm btn-danger "data-toggle =" modal "data-target =" #delete-modals "data-user =""> Business cards
No record found.

FAULT: Can not connect to the database!

modal


JS

$ (document) .ready (function () {

$ (# LstUsers #); dataTable ({
"iDisplayLength": 10,
"bAutoWidth": false,
"AoColumns": [
    { sWidth : "30%"},
    { sWidth : "55%"},
    { sWidth : "15%"},
          ],
& # 39; oLanguage & quot ;: {
& # 39; sPreface: {sFirst: & # 39; First & # 39; sLast; & nbsp; & nbsp; & nbsp; & nbsp; & nbsp; & nbsp; & nbsp; & nbsp; & nbsp; & nbsp; & nbsp; & nbsp; & nbsp; & nbsp; & nbsp; & nbsp; & nbsp; & nbsp; & nbsp; ... sNext: Next, sPrevious & # 39;
& # 39; sInfo & quot ;: "_TOTAL_ records found and showing (_START_ to _END_)",
& # 39; sSearch & # 39 ;: Search, & # 39;
& # 39; sInfoFiltered & # 39 ;: Total & # 39;
& # 39; sLengthMenu & # 39 ;: & # 39; Display  recordings. "
}
});

});

/ **
* Pass the email data to Modal and update the link to delete it.
* /

$ (document) .on (show.bs.modal, # delete-modals, function () {
console.log ("delete modal");

var button = $ (event.relatedTarget);
var email = button.data ('user');

var modal = $ (this);
modal.find (& # 39; modal-title & # 39;). text ('Delete email:' + email);
modal.find (& # 39; #confirm). attr ("href", "delete.php? email =" + email);
});