linux – apt install php7.1-curl depends on libcurl3 but i have libcurl4 installed

There seem to be other related issues on this, but I would like to ask mine to give it more specific content to my situation, if it helps to diagnose the problem and fix it.

I have several versions of PHP installed:
sudo update-alternatives --config php lists:

        0 /usr/bin/php7.3 73 auto mode
1 mode / usr / bin / php5.6 56 manual mode
* 2 /usr/bin/php7.1 71 manual mode
3 /usr/bin/php7.2 72 manual mode
4 mode / usr / bin / php7.3 73 manual

I'm trying to use PHP 7.1 for a project and I need to install curl. The problem is that it is continually failing installation due to addiction issues.

I can not install libcurl3 because it is not available (and it probably is not wise to do it, since libcurl4 is already installed).

libcurl4 is already the latest version (7.64.0-1).

I have tried different versions of PHP and tried to install the curl extension for each, as well as php-curl (usually) too. In vain.

Does any one have a solution?