I am refactoring some code and I came across two classes having pretty much the same function: it was a Java bean representation of an XML file, used to map elements (status and project name of different ticket systems).
One was "StatusMapping" and the other "ProjectsMapper".
I've renamed both using "Mapping" rather than "Mapping", but I was wondering if "Map" would also have been a worthwhile solution, knowing that it's mostly used when in use of java.util.Map.
I do not think it will make much difference, as long as I keep it in the code, but as a non-native English speaker:
- Is there a difference between using "map" or "map" or "mapping"?
- Maybe it depends on whether it's a class name or a service name or just a variable name?
This question is more about the object / class naming than about methods / functions, but feel free to integrate it.