network – Get a wifi connection WPA2

I've tried to get a simple wifi connection! But I must admit that I just can not do it!

here is what i've tried:

root @ MYONE: / etc # clear
root @ MYONE: / etc # vi wpa_supplicant.conf
ctrl_interface = / var / run / wpa_supplicant
ctrl_interface_group = 0
update_config = 1

network = {
ssid = "Mi Engine"
psk = "7407352688e4"
}


root @ MYONE: / etc # iw wlan0 link
Not connected.
root @ MYONE: / etc # ifconfig
eth0 Link Encapsulation: Ethernet HWaddr 74: FE: 48: 3A: 55: AB
inet addr: 192.168.178.88 Bcast: 192.168.178.255 Mask: 255.255.255.0
inet6 addr: fe80 :: 76fe: 48ff: fe3a: 55ab% 4804152/64 Scope: Link
UP BROADCAST RUNNING MULTICAST MTU: 1500 Metric: 1
RX Packages: 5268 Errors: 0 Aborted: 0 Overrides: 0 Image: 0
TX Packages: 7625 errors: 0 abandoned: 0 exceedances: 0 carrier: 0
collisions: 0 txqueuelen: 1000
RX Bytes: 345028 (336.9 KB) Bytes TX: 2899092 (2.7 MB)

eth1 Link encap: Ethernet HWaddr 74: FE: 48: 3A: 55: AC
UP BROADCAST MULTICAST MTU: 1500 Metric: 1
RX Packages: 0 errors: 0 abandoned: 0 exceedances: 0 image: 0
TX Packages: 0 errors: 0 abandoned: 0 exceedances: 0 carrier: 0
collisions: 0 txqueuelen: 1000
RX Bytes: 0 (0.0 B) TX Bytes: 0 (0.0 B)

lo Link encap: Local Loopback
inet addr: 127.0.0.1 Mask: 255.0.0.0
inet6 addr: :: 1% 4804152/128 Scope: host
UP LOOPBACK RUNNING MTU: 65536 Metric: 1
RX packages: 171 errors: 0 abandoned: 0 exceedances: 0 image: 0
TX Packages: 171 errors: 0 abandoned: 0 exceedances: 0 operator: 0
collisions: 0 txqueuelen: 1
RX Bytes: 13057 (12.7 KB) TX Bytes: 13057 (12.7 KB)

wlan0 Link Encapsulation: Ethernet Address 02: 00: EA: FF: D2: 06
UP BROADCAST MULTICAST MTU: 1500 Metric: 1
RX Packages: 0 errors: 0 abandoned: 0 exceedances: 0 image: 0
TX Packages: 0 errors: 0 abandoned: 0 exceedances: 0 carrier: 0
collisions: 0 txqueuelen: 1000
RX Bytes: 0 (0.0 B) TX Bytes: 0 (0.0 B)

So, my question what am I missing here and can solve it?
Thanks in advance!

Thanks in advance!