PHP ^7.1 meaning

Just to make something clear, when my Magento 2 module state:

   "require": {
    "php": "^7.1.0"
},

Does that mean that the module support PHP version 7.1 and higher or only 7.1?