php 7 – Error while updating Magento 2.3.0 (php required)

I am currently upgrading Magento from 2.2.7 to 2.3.0 from dial.
Run in sequence

php bin / maintenance magento: activate
composer require magento / product-community-edition 2.3.0 --no-update
composer's update 

In the console, I read several lines of error with sentences like

magento / framework 100.1.15 requires php ~ 5.6.5 | 7.0.2 | 7.0.4 | ~ 7.0.6 -> your version of PHP (7.1.23) does not meet this requirement.

Can only install one of the following: magento / framework[102.0.0, 101.0.0].

I'm using php v7.1.23 and, I'm not saying anything about the problem on v 7.1.x.

So, I do not understand why the upgrade is not compatible.

How does this problem occur? Should I upgrade to php v7.2?