php – Is there a vulnerability in the following code?

In my application, I have the next part of the code and I would like to know if she is vulnerable. In case something could be done, I would like to know how the vulnerability could be valid.

$ params = array ("param1", "param2", "param3");

for ($ i = 0; $ i <sizeof ($ params); $ i ++) {
if (isset ($ HTTP_POST_VARS[$params[$i]])) {
eval (" $$ params[$i] =
 "". trim ($ HTTP_POST_VARS[$params[$i]]). ""; ");
} elseif (isset ($ HTTP_GET_VARS[$params[$i]])) {
eval (" $$ params[$i] =
 "". trim ($ HTTP_GET_VARS[$params[$i]]). ""; ");
} other {
eval (" $$ params[$i] = & # 39 ;; ");
}

..

This is an old code, that is why HTTP_POST_VARS / HTTP_GET_VARS.

Thank you!