repository – Issues with Update Manager for Google Earth

Any help regarding the following error would be greatly appreciated. I've tried a few apt commands to clean it, but to no avail. I am using a Dell Latitude E6510 with LinuxM Mint 19. Thank you in advance for any help. John.

"An error occurred while checking the signature." The repository is not updated and the previous index files will be used GPG error: http://dl.google .com / linux / earth / deb stable Version: The following signatures were not valid: EXPKEYSIG 1397BC53640DB551 ​​Google Inc. (Signing Authority for Linux Packages) Unable to retrieve http://dl.google .com / linux / earth / deb / dist / stable / Release.gpg The following signatures were invalid: EXPKEYSIG 1397BC53640DB551 ​​Google Inc. (Linux) Failed to download certain index files. old ones are used instead. "