rstudio – Como comparar valores de uma mesma variavel e gerar uma outra variavel que ter o resultado dessa comparação no R

Oi, Bom Dia!

Tenho que reproduzir essa formula que fiz no excel: =SE(C2=C1;1+D1;1) para o R, mas não sei como fazer.

Eu tenho uma base onde uma das variaveis é o cargo de funcionarios, e eu preciso cria uma variavel que inumere os cargos que são iguais, dessa forma:

Cargo                    Numero do Cargo

Analista de BI                   1
Coordenador de Dados             1
Analista de BI                   2  
Analista de Dados                1
Analista de BI                   3 

Eu preciso criar essa coluna “Numero do Cargo”. Alguém sabe como fazer isso no R?

Agradeço desde já!