Should I force the high power web 2.0 expired

I have a high expired web 2.0 authority, in this manual article written in this and have pointed to my site for money.

What is my question is. In high authority, Web 2.0 would already suffice. If that's the case, should I use the Web 2.0 with GSA ser.