AutoRest v3 splits out Rest Clients by Controller

In AutoRest v2, by default it creates one single Rest Client with all the Controller actions within.

It seems in v3, it splits out a new Rest Client for each of the Controllers.

Any way to set an option in the CLI to not do that? apart from –legacy

hierarchy – How do you approach educating clients about “the fold” (and other UX ‘myths’)

I’ve always been of the belief that “the fold” is a bit of a misnomer, and indeed there’s a whole bunch of research (including material posted on this very site) suggesting that users don’t have a problem with scrolling down the page to explore content. While it’s obviously crucial that important information and calls to action are made visually prominent and easy locatable, this has always been more of a conversation around weighting of design and a ‘visual hierarchy’ to me.

Recently I’ve been working with a client who’s extremely focused around this concept of “the fold”, and the most important thing to them is making sure that X Y and Z all sit above the fold at all times.

I’ve tried to inform them that browser/resolution statistics and web-enabled devices are so variable there is no one true “page fold”, users will happily scroll down the page to continue reading content provided they are interested, and that it’s not necessary to cram all of content and functionality into the uppermost part of the page. They don’t seem to be buying it however, and I was wondering about how I could go about trying to get this message across.

In your experience, what is the best way to teach clients about the reality of “the fold” (and other myths like ‘the homepage must have everything’…) without just sending them links to web articles?

How to choose a CRM platform for communicating with clients?

How to choose a CRM platform for communicating with clients?

.

Design for multiple clients to iterate through entire database table

I need a design for multiple clients to process an entire database table, and processing each row independently and without overlap.

If there are 10,000 rows and 5 clients, each client will eventually process approximately 2,000 rows each. That is, the idea is to process all of the rows, using 1 to N workers, by having the workers each do only part of the work.

Conditions

  1. Each client will temporarily reserve a small set of rows, eventually marking one row in the working set as completed, and then release them all back to the pool of available rows. Rows are reserved in sets for performance reasons, but processed one row at a time. Processing one row is resource intensive and consumes significant clock time.
  2. Rows in the table must be processed approximately in decreasing row number order (it’s the primary key). I say approximately because if it makes things simpler, a bit of “randomness” or temporary gaps is OK.
  3. Every row must eventually be selected, and completed by one of the clients.

Additional details, if they matter to proposed designs:

  • Client requests arrive via HTTP.
  • There is private session data per client which can preserve client state.
  • Database is MySQL.
  • There is shared memory caching available, e.g. memcached and Redis.

This feels like a relatively common problem, but I wasn’t able to find any applicable writing in my web searches.

I’m looking for suggestions.

CISCO Configuration. DHCP & VLAN configured. But can’t ping other VLAN clients

I have created a network testing lab with CISCO Packet Tracer. I have performed the following to get a DHCP and VLAN (with Trucking) working:

  1. Configured Router interfaces (g0/0 + g0/0.10-0.50)
  2. Configured DHCP settings on Router
  3. Enabled Trunk on Router
  4. Configured VLAN on Switch
  5. Enabled Trunk on Switch

Below I post the >show run< for the router and the Switch. Workstations can gain an DHCP IP address, and VLAN segregation is working.

Workstations can ping the router but can’t ping other workstations on separate VLAN networks.

Router Configuration

shanelab#show run
Building configuration...

Current configuration : 2184 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname shanelab
!
!
!
enable secret 5 $1$mERr$xqDCepYvK4SAD6V0cxKQ3.
!
!
ip dhcp excluded-address 192.168.10.1 192.168.10.10
ip dhcp excluded-address 192.168.20.1 192.168.20.10
ip dhcp excluded-address 192.168.30.1 192.168.30.10
ip dhcp excluded-address 192.168.40.1 192.168.40.10
ip dhcp excluded-address 192.168.50.1
ip dhcp excluded-address 192.168.60.1
ip dhcp excluded-address 192.168.50.1 192.168.50.10
ip dhcp excluded-address 192.168.60.1 192.168.60.10
!
ip dhcp pool ITC
 network 192.168.10.0 255.255.255.0
 default-router 192.165.10.1
ip dhcp pool Manuf
 network 192.168.20.0 255.255.255.0
 default-router 192.168.20.1
ip dhcp pool billing
 network 192.168.30.0 255.255.255.0
 default-router 192.168.30.1
ip dhcp pool sales
 network 192.168.40.0 255.255.255.0
 default-router 192.168.40.1
ip dhcp pool HR
 network 192.168.50.0 255.255.255.0
 default-router 192.168.50.1
ip dhcp pool Management
 network 192.168.60.0 255.255.255.0
 default-router 192.168.60.1
!
!
!
ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO1941/K9 sn FTX1524KDLE-
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet0/0
 ip address 192.168.1.1 255.255.255.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/0.10
 encapsulation dot1Q 10
 ip address 192.168.10.1 255.255.255.0
!
interface GigabitEthernet0/0.20
 encapsulation dot1Q 20
 ip address 192.168.20.1 255.255.255.0
!
interface GigabitEthernet0/0.30
 encapsulation dot1Q 30
 ip address 192.168.30.1 255.255.255.0
!
interface GigabitEthernet0/0.40
 encapsulation dot1Q 40
 ip address 192.168.40.1 255.255.255.0
!
interface GigabitEthernet0/0.50
 encapsulation dot1Q 50
 ip address 192.168.50.1 255.255.255.0
!
interface GigabitEthernet0/0.60
 encapsulation dot1Q 60
 ip address 192.168.60.1 255.255.255.0
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
ip classless

shanelab#
shanelab#

Switch Configuration

Switch#show run
Building configuration...

Current configuration : 1385 bytes
!
version 15.0
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface FastEthernet0/1
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/2
 switchport access vlan 20
 switchport mode access
!
interface FastEthernet0/3
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/4
 switchport access vlan 40
 switchport mode access
!
interface FastEthernet0/5
 switchport access vlan 50
 switchport mode access
!
interface FastEthernet0/6
 switchport access vlan 60
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
 switchport mode trunk
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 shutdown
!
!
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
!
!
end


Switch#

Reply messages to clients or people. for $15

The service it offers is to read, recommend and answer the doubts and questions of its customers on social networks to people interested in its services or products. Either by Social Media by Email.

by: KotomySant
Created: —
Category: Email & Newsletters
Viewed: 154


.

windows – SoftEther: clients can’t communicate with each other

I’m trying to set up a LAN network through a SoftEther VPN server on Windows 10. (Purpose: play an old game that only works through LAN now.) I want to keep this VPN LAN separate from my own private LAN for security purposes.

What I’ve done is setup a SoftEther VPN server without local bridge. I’ve enabled the SecureNAT DHCP server:
SecureNAT settings

For testing I’ve used two PCs. My server and client A are on 192.168.1.33 in my private LAN, client B one is on 192.168.1.45. In the VPN LAN client A has IP 192.168.30.11, client B has IP 192.168.30.10.

This is the routing table of client A:

Network Destination        Netmask          Gateway       Interface  Metric
          0.0.0.0          0.0.0.0    192.168.1.254     192.168.1.33     25
        127.0.0.0        255.0.0.0         On-link         127.0.0.1    331
        127.0.0.1  255.255.255.255         On-link         127.0.0.1    331
  127.255.255.255  255.255.255.255         On-link         127.0.0.1    331
    130.158.6.116  255.255.255.255    192.168.1.254     192.168.1.33     25
      192.168.1.0    255.255.255.0         On-link      192.168.1.33    281
     192.168.1.33  255.255.255.255         On-link      192.168.1.33    281
    192.168.1.255  255.255.255.255         On-link      192.168.1.33    281
     192.168.30.0    255.255.255.0         On-link     192.168.30.11    257
    192.168.30.11  255.255.255.255         On-link     192.168.30.11    257
   192.168.30.255  255.255.255.255         On-link     192.168.30.11    257
        224.0.0.0        240.0.0.0         On-link         127.0.0.1    331
        224.0.0.0        240.0.0.0         On-link      192.168.1.33    281
        224.0.0.0        240.0.0.0         On-link     192.168.30.11    257
  255.255.255.255  255.255.255.255         On-link         127.0.0.1    331
  255.255.255.255  255.255.255.255         On-link      192.168.1.33    281
  255.255.255.255  255.255.255.255         On-link     192.168.30.11    257

The routing table on client B is similar (with 45 instead of 33 and 10 instead of 11).

From both clients I can ping 192.168.30.1 (the VPN server/SecureNAT IP). From both hosts I can ping the other one using their private LAN IPs (192.168.1.33 or .45). But whatever I do I can’t get the clients to reach each other using their VPN IPs. I’ve tried both pings and a simple web server to test this, with the same results.

How do I get this to work?

DNS : Hints to limit access to known clients

I would like to set up for personal purposes a DNS server on the cloud and offer its service to several members of my family/friends. Based on their IP and the filtering options they’d like, DNS queries will be performed in confidence (filter only ads, filter only non-appropriate sites for kids, etc…). In fact, a homemade OpenDNS solution.

To do so, I can use the directive allow-from (or equivalent) of my DNS solution but due to the DNS protocol nature, I can use only IP address/netmasks. This would work fine for people with public static IP addresses but not for people with a dynamic one.

I was thinking about using a reverse proxy that does support allow-from FQDN directive and forward the query to the local DNS server once the FQDN/IP matches.

What do you think about it? Is there any other/more straightforward solution/idea?

Wholesale & Dropshipping Sourcing agent seeking for ecommerce clients

Hi! I am Ken, who is a professional sourcing agent, with more than 10-year experience. We have established strong sourcing and logistics networks, helping many clients find or manufacture goods with satisfactory quality.

I can offer:

1) Sourcing

To find products from direct manufacturers based on your requirements in multiple platforms (1688, Taobao, Xianyu. etc), as well as hidden platforms that cannot be easily searched online (e.g.Electronic cigarette, you cannot find the source in 1688/Alibaba)

2)OEM
SEMrush

To manufacture your products within your budget. To negotiate with direct manufacturers to reduce your OEM expense.

3)One-Stop Delivery including:

– Warehousing

– Product inspection

– Branding

– Repackaging to reduce your shipping cost

– Shipping recommendation

If you are interested, please find out more information here and contact us. Thanks

 

reverse proxy – MTLS on the cheap that works on Android clients?

Is there a way to pull off MTLS/Two-Way SSL/Client Certificates that work on unrooted v10+ Android Clients on the cheap?

I’ve done the whole private setup with OpenSSL and it works absolutely fantastic with the lone exception of 3rd-Party Android Apps that use the default network security setting of only allowing system trust stores and ignore user trust stores. I’m sure there will be a valid reason for that being the default because of security and MITM exposure?

If you can only do it with public well-known root CA’s can you do it with a cheap DV then do your own CSR and generate your own client certs?

Setting up OpenVPN service and making tunnels seems like overkill in comparison?

Cheers