powershell – problem with robocopy on copying files from source to long distance destination

I am using robocopy $ source $ destination / MIR, the fact is that it copies the files in synchronization with the source but ignores the files and directories of the source which have long path names.

i wish i had a fix for that, i tried several ways but it didn't work.

CGI file does not work after copying to Word Doc and back

Word is a bit like HTML

There is what you see, then the "source code"

When you copy from Word, you get all of the Microsoft-specific source code that comes with it and your cgi program "can't process"

Paste into notebook, select all, copy, then save as cgi file

but no programming code should ever go near a Word page, ever. There are much better editors like netbeans, sublimetext, notepad ++ and even Microsoft's own notepad program

amazon web services – Can I delete the snapshots and AMI in the zone zone after successfully copying the AMI in another zone?

I have created a FRIEND in an Asian area, ap-southeast-1.
The associated snapshot is saved and of course cannot be deleted.

I then copied this FRIEND to eu-west-1.

Can I somehow get rid of ap snapshots and FRIEND?
I noticed that the snapshot is also copied to the destination area, so it should be fine, but I can't find any documents about it.

2013 – Improved performance of creating / copying files and folders (using code) in our large document library

We have a local SharePoint 2013 team site and we have a document library that contains around 29,000 +++ items, and these files are structured under around 4,000 folders and subfolders. now inside our server side event receiver, i use the following method to copy files and folders, as follows: –

private void copyfiles(SPItemEventProperties properties, SPListItem currentItem, string from, string to)
        {
    try
     {
      SPFolder folder = properties.Web.GetFolder(properties.Web.ServerRelativeUrl + "/Shared Documents/" + currentItem("ReferenceNumber") + "https://sharepoint.stackexchange.com/" + from + "https://sharepoint.stackexchange.com/");
      SPDocumentLibrary currentDL = (SPDocumentLibrary)properties.Web.GetList(properties.Web.ServerRelativeUrl + "/Shared Documents/");
      SPListItem softemplete = null;
      TaxonomyFieldValue taxFieldValue = currentItem("CustomerName") as TaxonomyFieldValue;

      var label = taxFieldValue.Label;
      var titlewithoutspecialchar = currentItem("Title").ToString().Replace("~", " ").Replace(""", " ").Replace("https://sharepoint.stackexchange.com/#", " ").Replace("%", " ").Replace("&", " ").Replace("*", " ").Replace(":", " ")
              .Replace("<", " ").Replace(">", " ").Replace("?", " ").Replace("https://sharepoint.stackexchange.com/", " ").Replace("\", " ").Replace("{", " ").Replace("}", " ").Replace("|", " ").Replace(".", " ");
       if (folder.ItemCount > 0)
          {
            SPList list = properties.Web.GetList(properties.Web.ServerRelativeUrl + "/Shared Documents/");
            SPQuery query = new SPQuery();
            query.Folder = folder;
            SPListItemCollection listitem = list.GetItems(query);
              foreach (SPListItem i in listitem)
               {
                 if ((i.Name.ToLower().Contains(currentItem("ReferenceNumber").ToString().ToLower() + " -") &&
                    (i.Name.ToLower().Contains("sof") || i.Name.ToLower().Contains("pof") || i.Name.ToLower().Contains("qo"))

                     )
                       ||
                     i.Name.ToLower().Contains("request for approval"))
                   {
                     softemplete = i;
                       if (softemplete != null)
                          {
                            byte() fileBytes = softemplete.File.OpenBinary();
                            string destUrl = properties.Web.ServerRelativeUrl + "https://sharepoint.stackexchange.com/" + currentDL.RootFolder.Url + "https://sharepoint.stackexchange.com/" +
                             currentItem("ReferenceNumber") + "https://sharepoint.stackexchange.com/" + to + "https://sharepoint.stackexchange.com/" + currentItem("ReferenceNumber") + " - " + label + " - " + titlewithoutspecialchar.Trim() + ".xlsx";
                             if (i.Name.ToLower().Contains("request for approval.oft"))
                                {
                                    destUrl = properties.Web.ServerRelativeUrl + "https://sharepoint.stackexchange.com/" + currentDL.RootFolder.Url + "https://sharepoint.stackexchange.com/" +
                                   currentItem("ReferenceNumber") + "https://sharepoint.stackexchange.com/"+to+"/Request for Approval.oft";
                                }
                              else if (i.Name.ToLower().Contains("request for approval.xlsm"))
                                {
                                    destUrl = properties.Web.ServerRelativeUrl + "https://sharepoint.stackexchange.com/" + currentDL.RootFolder.Url + "https://sharepoint.stackexchange.com/" +
                                   currentItem("ReferenceNumber") + "https://sharepoint.stackexchange.com/" + to + "/Request for Approval.xlsm";
                                }
                                try
                                {
                                    SPFile destFile = currentDL.RootFolder.Files.Add(destUrl, fileBytes, false);
                                }
                                catch
                                {
                                }
                            }

                        }
                    }
                }
            }
            catch
            {
            }


        }

Now this method takes enough time to finish copying (sometimes around 10 seconds), although I use the CAML query to find only the files in the desired folder usingquery.Folder = folder;. so can anyone provide advice on improving this method? as i think it is already set to the maximum, is this correct?

WP removes backslashes from $ latex $ tags when copying posts

I have a free blog hosted on wordpress.com. If I have a message with something like this:

$latex begin{bmatrix} 1 \ -1 end{bmatrix}$

And I copy the message, WP transforms the block in the copied version into this:

$latex begin{bmatrix} 1  -1 end{bmatrix}$

Note the missing backslashes at the beginning, at the end, and between the numbers. Is this a known bug? Is there an obvious solution when I want to copy a message and keep, well … everything?

seo – Google has deindexed portions of our page after copying the content

This year, our website has featured in a number of leading design articles and has subsequently been copied in-depth. Now, Google seems to have deindexed parts of our homepage (and perhaps other content), which worries our SEO and CTR rankings.

Moreover, it no longer reads the key parts of the page to present in SERP, rather converting our navigation into text. The results, as you can imagine, are very poor (see image).

enter the description of the image here

We are a Christian organization and we do not wish to pursue copyright infringement.

What can be done about this?

infopath – How to prevent the repetitive array from copying values ​​from the previous line

I have a repetitive table containing 3 fields (let's call them A, B and C). They are all connected to a list in SharePoint (data connection).

Columns A and B are both (cascaded) searches and C is a text field.

When you select a value in A, B is filtered. When a value is selected in B, C is automatically filled in.

Problem:
When I add a new line to the table, the values ​​in B and C are copied to this line.

What can I do to prevent this from happening?

Is it possible to sort a linked list without copying its values ​​but linking the nodes?

Is there an algorithm I could use when copying values ​​is not allowed? My list will be sorted in ascending order.

Can this also be done in quadratic time?

I will try this in Python.

Hard disk write speed increases from 150 MB / s to 2 MB / s when copying large files

When I copy 600 GB of large video files from hard drive F to hard drive G, once 100 GB is copied, the write speed of hard drive G starts to go from 150 MB / s to 1-2 Mo / s. When I cancel the copy, the drive remains 100% active for a long time because it continues to write files (cache of about 2.6 GB) from 1 MB / s.

When the memory write is complete and the G hard disk activity reaches 0%, I try to copy the files again, but the "memory cache" fills up in a few seconds and the hard drive has a speed of 1 to 2 MB / s almost from the beginning. So, effectively, if the reader clogs once, he continues to slow down even after the end of memory writing. The only way to remedy the slowness is to restart the PC. When I restart, the system is working properly until I copy large files, which causes the slowness mentioned.

I did the same copy experience on another hard drive L and the same problem occurs.

I've been trying to exchange SATA cables and plug it into different SATA ports, but that does not help me.

The motherboard has 6 SATA ports, 2x SATA3 and 4xsata2. All locations are used for some readers. F G L drives are plugged into two sata 2 ports. During copy experiments, no other intense processes are running.

Is it a problem of motherboard, RAM or hard drive?

PC: i7 lga1155, asrock pro4, 24 GB RAM, Seagate 4 TB drives.

icloud – Can I download all the files under the File application without copying them to the iPhone?

I want to download locally all the files from a directory of the iPhone File application, but there seems to be no choice but to select all the files and copy them.

However, I just want to download all the files locally, especially because sometimes the files are automatically deleted for some reason and I have to copy them again each time this happens.

The files are placed under iCloud and I put them from my Mac.