KALI LINUX BROKEN DEPENDS – Super User

i am in big trouble! i cannot install any package or script or whatever on my linux.
i got some problem with depends and cannot fix it. the error is this :

root@hizzly:/home/noroot/Downloads# dpkg -i libcogl-pango-dev_1.22.0-2_amd64.deb
(Reading database … 516907 files and directories currently installed.)
Preparing to unpack libcogl-pango-dev_1.22.0-2_amd64.deb …
Unpacking libcogl-pango-dev (1.22.0-2) over (1.22.0-2) …
dpkg: dependency problems prevent configuration of libcogl-pango-dev:
libcogl-pango-dev depends on libcogl-pango20 (= 1.22.0-2); however:
Version of libcogl-pango20:amd64 on system is 1.22.6-1.
libcogl-pango-dev depends on gir1.2-coglpango-1.0 (= 1.22.0-2); however:
Version of gir1.2-coglpango-1.0:amd64 on system is 1.22.6-1.
libcogl-pango-dev depends on libcogl-dev (= 1.22.0-2); however:
Package libcogl-dev is not installed.
libcogl-pango-dev depends on libglib2.0-dev (>= 2.28.0); however:
Package libglib2.0-dev is not installed.
libcogl-pango-dev depends on libcairo2-dev (>= 1.10); however:
Package libcairo2-dev is not installed.
libcogl-pango-dev depends on libdrm-dev; however:
Package libdrm-dev is not installed.
libcogl-pango-dev depends on libgdk-pixbuf2.0-dev (>= 2.0); however:
Package libgdk-pixbuf2.0-dev is not installed.
libcogl-pango-dev depends on libpango1.0-dev (>= 1.20); however:
Package libpango1.0-dev is not installed.
libcogl-pango-dev depends on libxcomposite-dev; however:
Package libxcomposite-dev is not installed.
libcogl-pango-dev depends on libxext-dev; however:
Package libxext-dev is not installed.
libcogl-pango-dev depends on libxfixes-dev; however:
Package libxfixes-dev is not installed.
libcogl-pango-dev depends on libxdamage-dev; however:
Package libxdamage-dev is not installed.

dpkg: error processing package libcogl-pango-dev (–install):
dependency problems – leaving unconfigured
Errors were encountered while processing:
libcogl-pango-dev

licensing – Can AGPL code depends on closed source code

I have a closed source module (A) in odoo that it working fine without depending on anything.

Now I would like to add an AGPL module(B) and integrate it with module (A).

So, I am planning to create another module(C) that does the integration between A and B.

I know that the module (C) should have an AGPL license. However what about module (A).

Can an AGPL code depend on closed source code giving that it doesn’t work without it?

In my case, do I have to distribute the source code of module A giving that module C doesn’t work without it.

Thank you in advance.

java – List with object and index filtering out the object depends upon the index present at list

I have a following list which indicates the indexes.

 List<Integer> integerList = Arrays.asList(1, 3, 5, 6); // index

I have the following collection of objects.

Collection<Test> testCollection = new ArrayList<>();

Test test01 = new Test(0, "A"); // 0
Test test02 = new Test(1, "B"); // 1
Test test03 = new Test(2, "C"); // 2
Test test04 = new Test(3, "D"); // 3
Test test05 = new Test(4, "E"); // 4
Test test06 = new Test(5, "F"); // 5

testCollection.add(test01);
testCollection.add(test02);
testCollection.add(test03);
testCollection.add(test04);
testCollection.add(test05);
testCollection.add(test06);

The integerList has indexes which are present on testCollection. I want to filter out the testCollection which will have object consisting the index 1, 3, 5. Index 6 is not present on object collection.

I wrote the code as below example. Is there any better as like Java 8 way?

List<Test> testList = new ArrayList<>(testCollection);
List<Test> newTestList = new ArrayList<>();

for (Integer integer : integerList) {

  for (int j = 0; j < testList.size(); j++) {

    if (integer == j) {
      newTestList.add(testList.get(j));
    }
  }
}
System.out.println(newTestList);

It will have the following output as result:

(Test{id=1, name='B'}, Test{id=3, name='D'}, Test{id=5, name='F'})

The class Test has following information.

class Test {
  private int id;
  private String name;
}

Finding a function of $Pois(lambda_1)$ and $Pois(lambda_2)$ such that the distribution depends on $frac{lambda_1}{lambda_1+lambda_2}$ only.

Suppose that $Xsim Pois(lambda_1)$ and $Ysim Pois(lambda_2)$ are two independent Poisson random variables. Can we find a function $f(X,Y)$ of $X$ and $Y$, where $f(X,Y)$ does not involve $lambda_1$ and $lambda_2$, such that the distribution of $Zequiv f(X,Y)$ depends on the parameter $frac{lambda_1}{lambda_1+lambda_2}$ only?

I know there is a result that $X|X+Y=n$ follows a binomial distribution with parameters $n$ and $frac{lambda_1}{lambda_1+lambda_2}$. But can we find a statistic $Z= f(X,Y)$ without conditioning such that $Z$ depends on the parameter $frac{lambda_1}{lambda_1+lambda_2}$ only?

I tried some naive functions such as $f(X,Y)=frac{X}{X+Y+1}$ and $f(X,Y)=frac{X}{X^2+Y^2+1}$, but it turns out that those functions do not work.

Debian: Cannot install php7.4-curl — depends not installable

I recently upgraded from debian9 (stretch) to debian10 (buster). Which also includes upgrading to php7.4. For some reason php-curl cannot install.

I run apt install php7.4-curl and the error I get is:

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 php7.4-curl : Depends: libcurl3 (>= 7.44.0) but it is not installable
E: Unable to correct problems, you have held broken packages.

I cannot see any held packages, anywhere. I have tried:

apt-mark showhold
dpkg --audit
dpkg --configure -a
apt-get install -f
apt-get clean
apt-get update
apt-get autoremove

I have also tried removing curl, purge, autoremove, and then reinstall. Same thing.

Prevnet value depends on ID

enter description of image here
how i can prevent duplicate value when custom_field_id = 2
but other custom_field_id sa allow duplicate value
.I have to choose depends with ID
.alter table custom_values
-I hope to help me

android – Because qrreaderapp depends on sqflite> = 1.1.7-dev.1 which requires the SDK version> = 2.5.0

I have this error in my application, how can I fix it? It appeared to me after trying to install 2 packages, that of sqflite and the path provider:

here is what i have in my pubspec.yaml:

version: 1.0.0+1

environment:
  sdk: ">=2.1.0 <3.0.0"

dependencies:
  flutter:
    sdk: flutter

  # The following adds the Cupertino Icons font to your application.
  # Use with the CupertinoIcons class for iOS style icons.
  cupertino_icons: ^0.1.2
  qrcode_reader: ^0.4.4
  sqflite: ^1.3.0
  path_provider: ^1.6.5

dev_dependencies:
  flutter_test:
    sdk: flutter

Two check boxes, one depends on the other

When Make public is checked, For review should be checked automatically.
I found the following code which is going through the code. I was asked to reformat with less if statements. I spend 2 hours just to make it work and I have no idea how to reformat it.

  const (isPublic, setIsPublic) = useState(false);
  const (isReviewNeeded, setIsReviewNeeded) = useState(false);

  const handlePublicCheckbox = () => {
        if (isReviewNeeded && isPublic) {
          setIsPublic(!isPublic);
          setIsReviewNeeded(!isReviewNeeded);

          return;
        }

        if (isReviewNeeded) {
          setIsPublic(!isPublic);

          return;
        }

        setIsPublic(!isPublic);
        setIsReviewNeeded(!isReviewNeeded);
      };

      const handleReviewCheckbox = () => {
        setIsReviewNeeded(!isReviewNeeded);
      };

Codesandbox for playing.

All thoughts are welcome 🙂

Depends on luck

Really, no one should depend on luck in the trade. You may be lucky once or twice, but not every time. In any case, you really need to understand what you are doing. It is the flawless work that ultimately pays off. If you do consistent work in the right way, you will get results. I trade forex with the broker XeroMarkets. I like the broker's platform. I love other than their advanced teaching materials. They are so precious to me.

How to package a Unity asset that depends on Addressables?

I am creating a Unity asset that I would like to publish on the Unity store. However, this asset depends on the Addressables package and obviously requires an addressable database which resides in a folder called AddressableAssetsData in the root directory of the Unity project.

If I don't include it in my package, the asset will not work and if I include it, it could conflict with the existing AddressableAssetsData of the user who installed my package.

Is it possible to move AddressableAssetsData to a subfolder of my own package or to configure it so as not to conflict with the future AddressableAssetsData structures of another user? What would you suggest?