Drivers – Install Cuda 10.0 on Ubuntu 16.04 (for DGX-1)

I'm trying to install CUDA-10.0 on Ubuntu 16.04 running on the DGX-1 server.
I followed the instructions for "installing the run file" in .html # runfile.

I chose to install the CUDA drivers, the CUDA toolkit and CUDA examples.

Previous versions of the Nvidia driver and CUDA have been removed with the help of (as suggested in How to install CUDA on Ubuntu 16.04?):

sudo apt-get purge nvidia-cuda*
sudo apt-get purge nvidia-*

After the stage 4.2.6 (ie reboot the system to reload the GUI.), I checked the CUDA version as follows:

nvcc --version
nvcc: NVIDIA (R) Cuda compiler driver
Copyright (c) 2005-2018 NVIDIA Corporation
Built on Sat_Aug_25_21:08:01_CDT_2018
Cuda compilation tools, release 10.0, V10.0.130

However, when I run "nvidia-smi", the following error appears:

NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

I went for a step 4.4 (Verification of the device node.) And found that the device files "/ dev / nvidia *" do not exist.
I've tried to create them manually, however, running "modprobe" returns an error:

sudo /sbin/modprobe nvidia
modprobe: ERROR: could not insert 'nvidia': Exec format error

Please help solve the problem. Thank you!

=============================================== === ======================
Other details.

lspci | grep -i nvidia
06:00.0 3D controller: NVIDIA Corporation GV100GL (Tesla V100 SXM2 32GB) (rev a1)
07:00.0 3D controller: NVIDIA Corporation GV100GL (Tesla V100 SXM2 32GB) (rev a1)
0a:00.0 3D controller: NVIDIA Corporation GV100GL (Tesla V100 SXM2 32GB) (rev a1)
0b:00.0 3D controller: NVIDIA Corporation GV100GL (Tesla V100 SXM2 32GB) (rev a1)
85:00.0 3D controller: NVIDIA Corporation GV100GL (Tesla V100 SXM2 32GB) (rev a1)
86:00.0 3D controller: NVIDIA Corporation GV100GL (Tesla V100 SXM2 32GB) (rev a1)
89:00.0 3D controller: NVIDIA Corporation GV100GL (Tesla V100 SXM2 32GB) (rev a1)
8a:00.0 3D controller: NVIDIA Corporation GV100GL (Tesla V100 SXM2 32GB) (rev a1)

uname -m && cat /etc/*release
VERSION="16.04.6 LTS (Xenial Xerus)"
PRETTY_NAME="Ubuntu 16.04.6 LTS"

gcc --version
gcc (GCC) 5.4.0
Copyright (C) 2015 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO

uname -r

cat /proc/version
Linux version 4.4.0-142-generic (buildd@lgw01-amd64-033) (gcc version 5.4.0 20160609 (Ubuntu 5.4.0-6ubuntu1~16.04.10) ) #168-Ubuntu SMP Wed Jan 16 21:00:45 UTC 2019

dpkg -l | grep nvidia
ii  dgx-peer-mem-loader                             1.1-10                                        amd64        Ensure nvidia is loaded before nv_peer_mem

Software Installation – Can not Install Discovery Studio Visualizer

I use Ubuntu 16.04 LTS. I have run the .bin file through a terminal to install DS Visualizer, but I have had the following errors:

./ 49: ./ [[: not found
./ 70: ./ Syntax error: redirection unexpected

lightning network – ELIFECYCLE error when trying to install filebazaar

Try to install FileBazaar on Ubuntu 18.04 and get an error on the canvas module … anyone who knows this problem? I've gone through the node-canvas github issues (like this one where I left a comment), but none of the solutions work for me right now.

Here is the command that I run:

$ sudo npm install -g filebazaar

And here is the error output:

$ sudo npm install -g canvas@1.6.13

> canvas@1.6.13 install /usr/local/lib/node_modules/canvas
> node-gyp rebuild

gyp ERR! configure error 
gyp ERR! stack Error: EACCES: permission denied, mkdir '/usr/local/lib/node_modules/canvas/build'
gyp ERR! System Linux 4.15.0-55-generic
gyp ERR! command "/usr/local/bin/node" "/usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild"
gyp ERR! cwd /usr/local/lib/node_modules/canvas
gyp ERR! node -v v12.5.0
gyp ERR! node-gyp -v v3.8.0
gyp ERR! not ok 
npm ERR! errno 1
npm ERR! canvas@1.6.13 install: `node-gyp rebuild`
npm ERR! Exit status 1
npm ERR! 
npm ERR! Failed at the canvas@1.6.13 install script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR!     /home/chris/.npm/_logs/2019-09-17T20_39_13_514Z-debug.log

Any help is appreciated 🙂

python – How to install salt for python3?

When I check my salt-minion version, I receive the following message:

(root@localhost ~)# salt-minion --version
/usr/lib/python2.7/site-packages/salt/ DeprecationWarning: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as
Python 2.7 won't be maintained after that date.  Salt will drop support for Python 2.7 in the Sodium release or later.
salt-minion 2019.2.0 (Fluorine)

My question is: how can I install Salt for python3, because salt packages are automatically installed in /usr/lib/python2.7/site-packages/salt/?

How to install Google Adsense sensitive ad codes on AMP blogs

Google AMP has tended lately and thousands of bloggers are turning to AMP reactive models everyday. The use of a website supported by AMP allows you to better position yourself in the search results and improve the user experience.

But AMP does not support normal implementation of Google Adsense Ads, which could reduce your adsense earnings. So today, I will discuss how to install Google Adsense ad codes on AMP Responsive blogs.

AMPProject Page made things easier with the provided guide to install a reactive AMP ad with amp-ad that supports multiple provisions such as Fill in the layouts, fixed, fixed height, flex-items, nodisplay and responsive. This (amp-ad) supports many ad providers, including Adsense.

Recently, Adsense started playing automatic detection of the announcement codes installed on amp reactive pages and also suggests some guides on installing AdSense reagent AMP ad code, slightly different from the AMPProject Page AMP ad code.

But there are tons of confused bloggers on the steps to implementing an AMP responsive ad code since Adsense, because once installed to replace the previous AMP-ad code, it may seem unknown and different.

READ ALSO >> How to change the color of the website address bar in the mobile browser
This is because AdSense Adaptive AMP ad code uses a unit width, either viewwidth or vw, or adjusts the width of the screen (the code appears: code width = " 100vw "). So, when you simply install to replace the previously installed amp-ad code, the width of the ads will adjust to the width of the screen. Which is bad when the ads are displayed on the desktop screen because they will collide with the sidebar and other widgets.

Below is the Adsense Reactive AMP Ad Code:

<amp-ad width = "100vw" height = 320
type = "adsense"
data-ad-client = "ca-pub-3597723085513015"
data-ad-slot = "8128208329"
data-auto-format = "rspv"

However, if you want to install it in Blogger, you need to make some adjustments so that the code can be stored in Edit HTML. You will find below the code that will be installed in Edit HTML.

<amp-ad width = "100vw" height = "320"
type = "adsense"
data-ad-client = "ca-pub-3597723085513015"
data-ad-slot = "8128208329"
data-auto-format = "rspv"
data-full-width = "">

The code above is not changed, it is simply adapted to the accepted code in Edit Blogger HTML. In Adsense AMP sensitive ad codes, it is not recommended to modify it so that ads can appear on the AMP page.

READ ALSO >> BREACH: The Court orders the CBN to pay 8 billion nairas to the community of Benue for the communities following the invasion of soldiers
Using a 320-pixel ad height, Adsense also explains that the size of this AMP-sensitive ad can be safely stored above the crease and below the crease.

Also note that Responsive Adsense Ads only displays on mobileFor ads to appear on desktops and mobiles without making mistakes, follow the steps below to install it.

In this case, we install 2 ad codes from the same location that will appear only on the desktop and mobile only with the help of Conditional mobile and desktop tags. So there are ads that appear only on the desktop and others that appear only on the mobile.

Please use the code as below.

In this way, the desktop display will not change while, in the mobile, ads with a full mobile phone screen width will appear, as it is a blog whose display is also full screen.

READ ALSO >> How to Add a Telegram Share Button for Blogger Blogs
Do not hesitate to ask in the comment section of something is not clear. I can be helpful.

It turns out that after using tags to add the media query as it applies to the image, the ad always appears at the limit of the specified query media. . So, with this ad not appearing outside of the media query that we display, this will give the blog a neat appearance with no space destroyed large enough because of this responsive AMP ad if desktop users access the URL of our mobile blog.

Please add the code media = "(max-width: 414px)" (the max-width code: 414px can be set as you like) in the Adsense Adaptive AMP Ad Code as follows.


I want to install Drupal 8 and I want to access it as http: /// drupal rather than at the root

I want to install drupal 8 and access it as http / // drupal rather than root.
But it does not respect the prefix "/ drupal /" for most of the admin part.
Can any one please help?

Can I install more than two desktop environments in the same computer?

I want to try a different desktop environment that my brothers use because it looks pretty good, but I have no experience using it. I was wondering if I could install it on my computer without removing existing computers.
KDE and gnome are installed on a computer and is it possible to install one more without removing any of the two existing ones?

Graphics – I need help to install amd drivers

I just went from Windows to Ubuntu, and I do not know how to install the driver configuration application, I have AMD A 10-9600 and I really need help. because the colors on my screen look very faded and i want to adjust the saturation from the AMD radeon settings app, but i can not find it and i do not know how to install it.

homebrew – brew cask install java6 – Can not install on volume / because disabled – MacOS 10.15 beta

I've uninstalled / reinstalled an infusion, disabled macOS Gatekeeper and many other things. brew cask install java6 always entails this:

> $ brew cask install java6                                        ⬡ 8.11.4 [±OLYM-152-optimizely-web-per-banner ✓]
==> Satisfying dependencies
==> Downloading
Already downloaded: /Users/mmooring/Library/Caches/Homebrew/downloads/ef0dff3db9496248774373eb3eba27a50a91e83edda3fe32d2197db15a5ffc69--javaforosx.dmg
==> Verifying SHA-256 checksum for Cask 'java6'.
==> Installing Cask java6
==> Running installer for java6; your password may be necessary.
==> Package installers may write to any location; options such as --appdir are ignored.
installer: Cannot install on volume / because it is disabled.
installer: A newer version of this package is already installed.
==> Purging files for version 1.6.0_65-b14-468 of Cask java6
Error: Failure while executing; `/usr/bin/sudo -E -- env LOGNAME=mmooring USER=mmooring USERNAME=mmooring /usr/sbin/installer -pkg /usr/local/Caskroom/java6/1.6.0_65-b14-468/JavaForOSX.pkg -target /` exited with 1. Here's the output:
installer: Cannot install on volume / because it is disabled.
installer: A newer version of this package is already installed.
Follow the instructions here:
/usr/local/Homebrew/Library/Homebrew/system_command.rb:111:in `assert_success'
/usr/local/Homebrew/Library/Homebrew/system_command.rb:52:in `run!'
/usr/local/Homebrew/Library/Homebrew/system_command.rb:29:in `run'
/usr/local/Homebrew/Library/Homebrew/system_command.rb:33:in `run!'
/usr/local/Homebrew/Library/Homebrew/cask/artifact/pkg.rb:59:in `block in run_installer'
/usr/local/Homebrew/Library/Homebrew/cask/artifact/pkg.rb:65:in `with_choices_file'
/usr/local/Homebrew/Library/Homebrew/cask/artifact/pkg.rb:52:in `run_installer'
/usr/local/Homebrew/Library/Homebrew/cask/artifact/pkg.rb:34:in `install_phase'
/usr/local/Homebrew/Library/Homebrew/cask/installer.rb:214:in `block in install_artifacts'
/System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/lib/ruby/2.6.0/set.rb:777:in `each'
/System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/lib/ruby/2.6.0/set.rb:777:in `each'
/usr/local/Homebrew/Library/Homebrew/cask/installer.rb:205:in `install_artifacts'
/usr/local/Homebrew/Library/Homebrew/cask/installer.rb:103:in `install'
/usr/local/Homebrew/Library/Homebrew/cask/cmd/install.rb:23:in `block in run'
/usr/local/Homebrew/Library/Homebrew/cask/cmd/install.rb:16:in `each'
/usr/local/Homebrew/Library/Homebrew/cask/cmd/install.rb:16:in `run'
/usr/local/Homebrew/Library/Homebrew/cask/cmd/abstract_command.rb:36:in `run'
/usr/local/Homebrew/Library/Homebrew/cask/cmd.rb:92:in `run_command'
/usr/local/Homebrew/Library/Homebrew/cask/cmd.rb:158:in `run'
/usr/local/Homebrew/Library/Homebrew/cask/cmd.rb:123:in `run'
/usr/local/Homebrew/Library/Homebrew/cmd/cask.rb:9:in `cask'
/usr/local/Homebrew/Library/Homebrew/brew.rb:102:in `

I've tried and answers this Apple StackExchange question:
How to run an application that requires the Java SDK on macOS Catalina 10.15?

Any help will be greatly appreciated because I am stuck for a few days. 🙇🏻♂️

apt – How to install the latest versions of rbenv and ruby-build?

I'm installing rbenv as follows:

$ sudo apt-get install rbenv

This installs rbenv@1.1.1 and ruby-build@20170726.

When I try to use these versions to install ruby, I can not install any version higher than 2.5.0-dev

How can I install higher versions of rbenv and ruby-build?

Is there another repository that I can add to sources.list?