Installing MySql 8.0.22 Shows options Grayed out when installing

I have Windows Server 2016 Datacenter.

I need to install MySqL 8.0.22 and the options are all greyed out, even when I attempt the non web installer ??

Any ideas why this might be happening ??

install image 1

install image 2

giving error "Too many arguments, expected arguments "command"." while installing magento 2.4

gatting error "Too many arguments, expected arguments "command"." while installing magento2.4 through command line.

enter image description here

memory – My computer is turning off and on again while installing Windows 10 for the first time

My computer is turning off and on again while installing Windows 10 for the first time.

I just built a PC with the following SPECS:

  • Msi Mag Vampiric 010 (Case)
  • Corsair TX 750W (CMPSU-750TX)
  • Gigabyte Intel Z490 Aorus Elite AC
  • Intel Core i7-10700K
  • DDR4 16gb 3200mhz Dimm HyperX Fury Black x 2 (32 GB)
  • SSD 500GB Kingston A2000, M.2 2280, NVMe PCIe
  • WD Black WD1001FALS 1TB 7200 RPM 32MB Cache SATA 3.0Gb/s
  • BE QUIET! PURE LOOP 280MM – NA0000050186
    Everything is new except the PSU which I bought 11 years ago.
    It works fine in my old computer.

The motherboard has 3 ATX power connectors (24 pin, 8 pin and 4 pin).
My power supply has only a 24 pin and 8 pin, so I only connected those.

  • Is there a “y-cable” splitter from 8 pin to 8 pin and 4 pin or something like that?
  • Could I use one of the PCIe or SATA power cables with some sort of adapter?
  • Is it mandatory to connect the 4 pin cable?

I have read all sorts of opinions but they usually says it’s ok not to unless you overclock the CPU.

I am able to enter the BIOS and edit settings. I have flashed the BIOS with the new version (and back to other older versions) without any issues.

When I tried installing Windows for the first time, the computer rebooted (before I was able to finish the first screen of the setup wizard).

I removed 16GB of RAM and tried again but failed.

I removed the other 16GB and put back the first one.

When I tried again I was able to complete the first part of the installation process (until the first oficial reboot).

When Windows rebooted, the computer powered off again.

  • I guess it wasn’t the RAM so I put both 16GB back on?!

I will try another PSU just in case.
I will also check if temperature is an issue… not sure how to measure it… maybe the BIOS records its history.

  • Is there another thing I should try?
  • Any bootable USB with diagnosis tools I could use?

Thanks for your help.

Installing Drupal 9 with Composer creates a .gitignore file that does not match what I see on drupal.org

Installing Drupal 9 with drupal/core-recommended:^9.1, I wind up with a docroot that has a .gitignore file. This is its contents:

/.csslintrc
/.eslintignore
/.eslintrc.json
/.ht.router.php
/.htaccess
/INSTALL.txt
/README.txt
/autoload.php
/example.gitignore
/index.php
/robots.txt
/update.php
/web.config

This does not match what I see on drupal.org or example.gitignore – is this a newer change?

I also had .editorconfig appended to my root gitignore. I cannot find anywhere in the codebase that would write to either of these files.

composer.json:

    "repositories": [
        {
            "type": "composer",
            "url": "https://packages.drupal.org/8"
        }
    ],
    "require": {
        "composer/installers": "^1.9",
        "cweagans/composer-patches": "^1.6.5",
        "drupal/core-composer-scaffold": "^9.1",
        "drupal/core-project-message": "^9.1",
        "drupal/core-recommended": "^9.1",
        "drush/drush": "^10.0"
    },
    "conflict": {
        "drupal/drupal": "*"
    },
    "minimum-stability": "dev",
    "prefer-stable": true,
    "config": {
        "sort-packages": true
    },
    "extra": {
        "drupal-scaffold": {
            "locations": {
                "web-root": "docroot/"
            }
        },
        "installer-paths": {
            "docroot/core": [
                "type:drupal-core"
            ],
            "docroot/libraries/{$name}": [
                "type:drupal-library"
            ],
            "docroot/modules/contrib/{$name}": [
                "type:drupal-module"
            ],
            "docroot/profiles/contrib/{$name}": [
                "type:drupal-profile"
            ],
            "docroot/themes/contrib/{$name}": [
                "type:drupal-theme"
            ],
            "drush/Commands/contrib/{$name}": [
                "type:drupal-drush"
            ],
            "docroot/modules/custom/{$name}": [
                "type:drupal-custom-module"
            ],
            "docroot/themes/custom/{$name}": [
                "type:drupal-custom-theme"
            ]
        },
        "drupal-core-project-message": {
            "include-keys": [
                "homepage",
                "support"
            ],
            "post-create-project-cmd-message": [
                "<bg=blue;fg=white>                                                         </>",
                "<bg=blue;fg=white>  Congratulations, you’ve installed the Drupal codebase  </>",
                "<bg=blue;fg=white>  from the drupal/recommended-project template!          </>",
                "<bg=blue;fg=white>                                                         </>",
                "",
                "<bg=yellow;fg=black>Next steps</>:",
                "  * Install the site: https://www.drupal.org/docs/8/install",
                "  * Read the user guide: https://www.drupal.org/docs/user_guide/en/index.html",
                "  * Get support: https://www.drupal.org/support",
                "  * Get involved with the Drupal community:",
                "      https://www.drupal.org/getting-involved",
                "  * Remove the plugin that prints this message:",
                "      composer remove drupal/core-project-message"
            ]
        }
    }

Edit:

Looks like the core-composer-scaffold package does this with the vendor/drupal/core-composer-scaffold/ManageGitIgnore.php class. How can I prevent it from writing to gitignore files?

Mechanics for Explorers installing cyber implants?

One of my players (naturally, magos) wants to install an implant (sub-derman armour for now) into himself. How can i handle that mechanically?

I am guessing something to the effect of madicae test or such with certain degrees of failure lowering implant effectiveness. But maybe that problem is already solved?..

Installing from adb installs app for all users

I have a LineageOS 17.1 system on Pocophone F1, unrooted. When I install an apk through USB using adb, adb not run as root, the app is installed both on my main admin user and on a secondary user on my phone. How do I force adb to only install the app for my main user only?

installation – Problem in installing Matex

I am using Mathematica 12.0, and I want to install Matex. According to this page
https://github.com/szhorvat/MaTeX

only writing the code ResourceFunction["MaTeXInstall"][] should work, but I get this error

enter image description here

I have downloaded “MaTeX-1.7.8.paclet” and put it in drive C, but the problem still persists.

Can someone please guide me where I am going wrong? I am not good at installing software and so on, maybe it is so simple.

magento2 – Error while installing sample data in magento 2.4.1

enter image description hereRecently I have installed the Magento 2.4.1 community edition in Ubuntu 20.04, Installation went correct and while I try to set sample data I got the below error
Unable to apply data patch MagentoCatalogRuleSampleDataSetupPatchDataInstallCatalogRuleSampleData for module Magento_CatalogRuleSampleData. Original exception message: Rolled back transaction has not been completed correctly.

I have searched about this issue and tried all the solution which have been provided

Tried solutions:

  1. Switch to developer mode before installing sample data
  2. Using MySQL 5.7
  3. Remove the sample data and rerun again
  4. Remove the corn job before installing the sample data
    but none of the solutions worked for me. as a temporary fix, I have disabled the Magento_CatalogRuleSampleData Magento_SalesRuleSampleData and using the local site.

Environment details:
I am using
ubuntu 20.04
PHP 7.3.25
apache 2.4.46
MYSQL 5.7.32
elastic search 7.6.0
Magento 2.4.1

Anybody, please suggest a proper fix for this issue.

installation – How do I get rid of “encoding error” when installing WordPress?

When trying to install WordPress on the Server it says that the encoding of the file is incorrect and I cannot even select the language.
This is the error code.

The character encoding of the HTML document was not declared.
The document will render with garbled text in some browser configurations
if the document contains characters from outside the US-ASCII range.
The character encoding of the page must be declared in the document or in the transfer protocol.

I tried to install the software on Mamp and there it works.
I tried uploading it to multiple directories and created different subdomains. It does not work.

What is the problem?

python 3.8 – rasa nlu is not installing

Hi

I am trying to install rasa nlu as it is not installed when I have installed rasa, how ever it shows this error for me that I am trying to solve for 3 days but I could not:

firstly I typed this command in the terminal:

pip install rasa-nlu

and this is the error:

ERROR: Command errored out with exit status 1:
     command: /Users/zahraaal-nemer/Desktop/rasa-init-demo/venv2/bin/python -c 'import sys, setuptools, tokenize; sys.argv(0) = '"'"'/private/var/folders/sm/bjkmpsf90ng76c26v82cg1j80000gn/T/pip-install-0ihvpl37/matplotlib_1de8f9c6a2d84b51a16a98ceeaf2c2d1/setup.py'"'"'; __file__='"'"'/private/var/folders/sm/bjkmpsf90ng76c26v82cg1j80000gn/T/pip-install-0ihvpl37/matplotlib_1de8f9c6a2d84b51a16a98ceeaf2c2d1/setup.py'"'"';f=getattr(tokenize, '"'"'open'"'"', open)(__file__);code=f.read().replace('"'"'rn'"'"', '"'"'n'"'"');f.close();exec(compile(code, __file__, '"'"'exec'"'"'))' egg_info --egg-base /private/var/folders/sm/bjkmpsf90ng76c26v82cg1j80000gn/T/pip-pip-egg-info-p1vu7ilr
         cwd: /private/var/folders/sm/bjkmpsf90ng76c26v82cg1j80000gn/T/pip-install-0ihvpl37/matplotlib_1de8f9c6a2d84b51a16a98ceeaf2c2d1/
    Complete output (106 lines):
    IMPORTANT WARNING:
        pkg-config is not installed.
        matplotlib may not be able to find some of its dependencies
    ============================================================================
    Edit setup.cfg to change the build options
    
    BUILDING MATPLOTLIB
                matplotlib: yes (2.2.5)
                    python: yes (3.8.1 (v3.8.1:1b293b6006, Dec 18 2019,
                            14:08:53)  (Clang 6.0 (clang-600.0.57)))
                  platform: yes (darwin)
    
    REQUIRED DEPENDENCIES AND EXTENSIONS
                     numpy: yes (version 1.18.5)
          install_requires: yes (handled by setuptools)
                    libagg: yes (pkg-config information for 'libagg' could not
                            be found. Using local copy.)
                  freetype: no  (The C/C++ header for freetype2 (ft2build.h)
                            could not be found.  You may need to install the
                            development package.)
                       png: no  (pkg-config information for 'libpng' could not
                            be found.)
                     qhull: yes (pkg-config information for 'libqhull' could not
                            be found. Using local copy.)
    
    OPTIONAL SUBPACKAGES
               sample_data: yes (installing)
                  toolkits: yes (installing)
                     tests: no  (skipping due to configuration)
            toolkits_tests: no  (skipping due to configuration)
    
    OPTIONAL BACKEND EXTENSIONS
                    macosx: yes (installing, darwin)
    IMPORTANT WARNING:
        pkg-config is not installed.
        matplotlib may not be able to find some of its dependencies
    IMPORTANT WARNING:
        pkg-config is not installed.
        matplotlib may not be able to find some of its dependencies
    IMPORTANT WARNING:
        pkg-config is not installed.
        matplotlib may not be able to find some of its dependencies
    IMPORTANT WARNING:
        pkg-config is not installed.
        matplotlib may not be able to find some of its dependencies
                    qt5agg: no  (PySide2 not found; PyQt5 not found)
    IMPORTANT WARNING:
        pkg-config is not installed.
        matplotlib may not be able to find some of its dependencies
    IMPORTANT WARNING:
        pkg-config is not installed.
        matplotlib may not be able to find some of its dependencies
    IMPORTANT WARNING:
        pkg-config is not installed.
        matplotlib may not be able to find some of its dependencies
    IMPORTANT WARNING:
        pkg-config is not installed.
        matplotlib may not be able to find some of its dependencies
                    qt4agg: no  (PySide not found; PyQt4 not found)
    IMPORTANT WARNING:
        pkg-config is not installed.
        matplotlib may not be able to find some of its dependencies
    IMPORTANT WARNING:
        pkg-config is not installed.
        matplotlib may not be able to find some of its dependencies
    IMPORTANT WARNING:
        pkg-config is not installed.
        matplotlib may not be able to find some of its dependencies
    IMPORTANT WARNING:
        pkg-config is not installed.
        matplotlib may not be able to find some of its dependencies
                   gtk3agg: no  (Requires pygobject to be installed.)
    IMPORTANT WARNING:
        pkg-config is not installed.
        matplotlib may not be able to find some of its dependencies
    IMPORTANT WARNING:
        pkg-config is not installed.
        matplotlib may not be able to find some of its dependencies
    IMPORTANT WARNING:
        pkg-config is not installed.
        matplotlib may not be able to find some of its dependencies
    IMPORTANT WARNING:
        pkg-config is not installed.
        matplotlib may not be able to find some of its dependencies
                 gtk3cairo: no  (Requires cairocffi or pycairo to be installed.)
                    gtkagg: no  (Requires pygtk)
                     tkagg: yes (installing; run-time loading from Python Tcl /
                            Tk)
                     wxagg: no  (requires wxPython)
                       gtk: no  (Requires pygtk)
                       agg: yes (installing)
                     cairo: no  (cairocffi or pycairo not found)
                 windowing: no  (Microsoft Windows only)
    
    OPTIONAL LATEX DEPENDENCIES
                    dvipng: no
               ghostscript: no
                     latex: no
                   pdftops: no
    
    OPTIONAL PACKAGE DATA
                      dlls: no  (skipping due to configuration)
    
    ============================================================================
                            * The following required packages can not be built:
                            * freetype, png
    ----------------------------------------
ERROR: Command errored out with exit status 1: python setup.py egg_info Check the logs for full command output.
WARNING: You are using pip version 20.3.1; however, version 20.3.3 is available.
You should consider upgrading via the '/Users/zahraaal-nemer/Desktop/rasa-init-demo/venv2/bin/python -m pip install --upgrade pip' command.

can anyone help me? I really researched a lot and tried many times but did not find the solution, its been 3 days till now

I am using terminal on MacOS