Termux – help to installing the boostrap packages

Termux is say unable to install the bootstrap packages in itel 1516 plus pls help me.

updating – What is the best practice for handling abandoned packages required by the drupal core?

When I run composer update on a Drupal 9 website, I get this warning:

Package doctrine/reflection is abandoned, you should avoid using it. Use roave/better-reflection instead.

A similar question has alreday been asked, answered and accepted on StackOverflow.

To summarise the accepted answer:

  • edit your composer.json and replace the abandoned package with the recommended replacement
  • then run composer update again

However, that answer doesn’t apply in the case of “doctrine/reflection”. When looking into my composer.json, there is no mention of it, so there is nothing to edit.

So I am checking why it is required:

$ composer why doctrine/reflection
doctrine/common          2.13.3  requires  doctrine/reflection (^1.0)   
doctrine/persistence     1.3.8   requires  doctrine/reflection (^1.2)   
drupal/core              9.1.7   requires  doctrine/reflection (^1.1)   
drupal/core-recommended  9.1.7   requires  doctrine/reflection (1.2.2)  

So this abandoned package is required by drupal/core (and others).

Two questions:

  1. Why is the most recent version of drupal/core requiring an abandoned package (instead of its recommended replacement roave/better-reflection)?
  2. What is the best practice for handling abandoned packages required by the drupal core?

Exporting packages containing “Python Code” cells

I created a notebook with Python code cells (evaluated using External Evaluate) as can be created by typing > at the beginning of a cell. (And choosing Python for the external evaluator). I then marked these cells as initialization cells. However, I find that I can’t reliably create packages (I create packages autoamtically using the answer in https://mathematica.stackexchange.com/a/31323/45020). The python cells do become python cells in the package but they get corrupted. It wrongly breaks cells up at any double new line (this can at least be avoided) but also randomly misses text. A cell with

import scipy.optimize
import numpy as np
def stuff():
...

just becomes
import scipy.optimize
import numpy as
def stuff():

and thus gives a syntax error since np is missing. The original notebook file works perfectly and has no such errors.

Is there any reliable way to export? Does everyone have these issues?

Version: “12.1.1 for Linux x86 (64-bit) (June 19, 2020)”


It gets even weirder. There seems to be some randomness to it. Now I managed to (without making changes) export it correctly to a package that does not produce any errors when run from within MMA (i.e. when opening it and running all the cells.) However, when calling it from another notebook using Get I still get a syntax error. I checked and see no syntax error in the cell where it should supposedly be.


It might be related to having set up a custom virtual environment using this answer. However, everything is working perfectly in the notebook. The issues only arise when converting to a package.

sql server 2008 – Can SSIS packages call other SSIS packages in the connection string?

I am running an SSIS package that transfers data from one (SQL2008) server to another (SQL2000). However after P2V conversion the SQL2008 server cannot execute an SSIS package due to a user authentication error.

Lets say the package is called “Transfer-Go”. In the connection string of that package can it call another SSIS package? In the SSIS library there is another package with the same that appears in the string (called Transfer-Now) name The string is below:

Data Source=<IP>;User ID=<user>;Initial Catalog=<db_name>;Provider=SQLNCLI10.1;Persist Security Info=True;OLE DB Services=-13;Auto Translate=False;Application Name=SSIS-<Transfer-Now-name of other SSIS package>-{8ABA18EE-637E-424F-A3F7-F7E4EA50DD9D}<IP.db_name.user>;

So is this SSIS package connection string calling that package?

And if the credentials are wrong in that package could that be why I am unable to authenticate?

Thanks for any input, not a DB/SQL guy at all so I apologize if I sound green here.

macos – Cant update/install homebrew packages with Kaspersky Security Software (Self Signed Cert)

At work we have Kaspersky installed. Kaspersky installs a self signed cert so it can decrypt/inspect web traffic. Chrome and everything works fine except for homebrew. When i try to install/update software this is what i see:

brew install yarn
==> Downloading https://yarnpkg.com/downloads/1.22.10/yarn-v1.22.10.tar.gz
######################################################################## 100.0%##O#- #
curl: (35) error:1400443E:SSL routines:CONNECT_CR_SRVR_HELLO:tlsv1 alert inappropriate fallback
Error: Failed to download resource "yarn"
Download failed: https://yarnpkg.com/downloads/1.22.10/yarn-v1.22.10.tar.gz

Since it appears its a curl issue i tried to create a .curlrc file with insecure but that doesn’t help at all. I’m able to call one of our IT admins over and temporarily turn off web anti-virus but that is starting to be a major pain every time i install/update software. They aren’t, of course, going to allow me to permantely turn it off. I have this issue on no matter what mac i use (one is a m1 based mac and the other is an intel based mac).

Composer require drupal/social_auth_google – Your requirements could not be resolved to an installable set of packages

Previously I got an error with the command

composer require "drupal/social_auth_google:^2.0"

So I tried;

composer require "drupal/social_api:2.x-dev" "drupal/social_auth:2.x-dev" "drupal/social_auth_google:2.x-dev" 

But now composer throws up faults no matter what I do. I tried removing all the “social” entries from composer.json but here are the errors I get instead;

 Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Root composer.json requires drupal/title_field_for_manage_display ^1.0, found drupal/title_field_for_manage_display(1.0.0, ..., 1.12.0) but the package is fixed to 2.0.0 (lock file version) by a partial update and that version does not match. Make sure you list it as an argument for the update command.
  Problem 2
    - Root composer.json requires drupal/social_auth_google ^2.1 -> satisfiable by drupal/social_auth_google(2.1.0).
    - drupal/social_auth_google 2.1.0 requires drupal/social_auth ^2.0 -> drupal/social_auth is fixed to 2.x-dev (lock file version) by a partial update but that version is rejected by your minimum-stability. Make sure you list it as an argument for the update command.

Use the option --with-all-dependencies (-W) to allow upgrades, downgrades and removals for packages currently locked to specific versions.

Installation failed, reverting ./composer.json and ./composer.lock to their original content.

So now composer doesn’t work at all. How can I fix composer?

packages – Get notation rule list so far

One can get list of every variable name so far by

Names("Global`*")

Likewise, is there a code to get list of every user-defined notation rule(using notation package) so far? like

NotaionRuleDefined("Global`*")

In that list, can I distinguish whether a notation rule is effective at present /or not?

magento2.3 – Composer can’t install any module due to “Your requirements could not be resolved to an installable set of packages”

Running 2.3.6
When I try to install any module via composer I get the following error:

 ()$ COMPOSER_MEMORY_LIMIT=-1 composer require stripe/stripe-php:^7
Warning from https://repo.packagist.org: You are using an outdated version of Composer. Composer 2 is now available and you should upgrade. See https://getcomposer.org/2
./composer.json has been updated
Loading composer repositories with package information
Warning from https://repo.packagist.org: You are using an outdated version of Composer. Composer 2 is now available and you should upgrade. See https://getcomposer.org/2
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Conclusion: remove magento/product-community-edition 2.3.6
    - Conclusion: don't install magento/product-community-edition 2.3.6
    - Installation request for magento/product-community-edition 2.3.6 -> satisfiable by magento/product-community-edition(2.3.6).
    - Installation request for veriteworks/cookiefix ^3.0 -> satisfiable by veriteworks/cookiefix(3.0.0).
    - Conclusion: don't install magento/framework 102.0.6-p1
    - magento/product-community-edition 2.3.6 requires laminas/laminas-code ~3.3.0 -> satisfiable by laminas/laminas-code(3.3.2, 3.3.0, 3.3.1).
    - Can only install one of: laminas/laminas-code(3.4.1, 3.3.0).
    - Can only install one of: laminas/laminas-code(3.4.1, 3.3.1).
    - Can only install one of: laminas/laminas-code(3.4.1, 3.3.2).
    - Can only install one of: laminas/laminas-code(3.4.1, 3.3.2).
    - Can only install one of: laminas/laminas-code(3.4.1, 3.3.2).
    - Conclusion: install magento/framework 102.0.6-p1|install laminas/laminas-code 3.4.1


Installation failed, reverting ./composer.json to its original content.

Is it possible i made a mess since few days ago (before that I think everything was working fine) and then I launched “composer dump-autoload -o” for some reason? If it’s that, is it possible to get back to previous version?

How to use conda to install packages in a docker container which has no access to the internet via ssh tunnel

I am able to ssh to a docker container running on a remote server.
The container has no access to the internet.

Request:
I want to set up my deep leaning environment in the container.

Things I can do now
Data transfer between my host and the docker container is fast.

Things I do not know how to

  1. Using conda to install packages.
  2. Using pip to install packages.

Immature solution
Using conda proxy to install packages directly inside the docker container.
I do not know how to forward the http/https request through ssh tunnel from the docker container to the destination.

I think it might be:

  1. First configure proxy server for conda throught modifying ~/.condarc as
proxy_servers:
    http: http://localhost:9998
    https: https://localhost:9998
  1. Then ssh from my PC to the container using command like:
ssh -p port kd@mlp -R 9998:someIP:80

I tried to replace someIP with localhost or https://repo.anaconda.com/pkgs/main. None of both helps.

Is the above solution possible? What would the ssh command be look like?

Noticed that:

  1. Since there are some packages not provided by pip, conda is necessary.
  2. I have no access to the remote host and am only able to ssh to the docker container.
  3. I can not modify the docker image or relaunch the docker container.

linux – How to interpret received packages, although not being destination host

Being:

  • Victim: 192.168.0.2
  • Attacker (also having SSH server installed): 192.168.0.3
  • SSH server: 192.168.0.4

I perform a succesfull ARP Spoofing attack (being obviously the attackers MAC address):

victim shell shown

But when I try to connect via ssh user@192.168.0.4, instead of connecting to the attackers ssh server, it redirects the traffic to the real ssh server (or keeps waiting for this connection if
traffic redirect is disabled in attackers /proc/sys/net/ipv4/ip_forward file).

Is there any way I could interpret packages coming from an IP before redirecting to the original destination?

Thank you in advance.

Note: in case it’s relevant, im using dockers inside GNS3 inside a VM, those dockers being Ubuntu. This is the scheme:
enter image description here