try to install php 7.1 on debian 9.8 – apt-get issue

I have php 7.0 / nginx on my debian server. I would like to upgrade it to at least PHP 7.1. Following the guide on https://launchpad.net/~ondrej/+archive/ubuntu/php I have encountered a lot of problems.

groot @ vps149861: /etc/apt # sudo apt-add-repository ppa: ondrej / nginx
password:
This branch follows the latest NGINX Stable packages compiled with the latest OpenSSL support for HTTP / 2 and TLS 1.3.

BUGS & CHARACTERISTICS: This app now has a problem tracking tool: https://deb.sury.org/#bug-reporting

PLEASE READ CAREFULLY: If you like my job and want to give me some motivation, consider donating: https://donate.sury.org
More info: https://launchpad.net/~ondrej/+archive/ubuntu/nginx
press [ENTER] to continue or ctrl-c to cancel the addition

gpg: keybox & # 39; /tmp/tmpd49klpme/pubring.gpg' created
gpg: /tmp/tmpd49klpme/trustdb.gpg: created trustdb
gpg: key 4F4EA0AAE5267A6C: public key "Launchpad PPA for Ondřej Surý" imported
gpg: Total number processed: 1
gpg: imported: 1
gpg: no valid OpenPGP data found.
Exception in thread Thread-1:
Traceback (last most recent call):
"/Usr/lib/python3.5/threading.py" file, line 914, in _bootstrap_inner
self.run ()
"/Usr/lib/python3.5/threading.py" file, line 862, in progress
self._target (* self._args, ** self._kwargs)
"/Usr/lib/python3/dist-packages/softwareproperties/SoftwareProperties.py" file, line 688, in addkey_func
func (** kwargs)
"/Usr/lib/python3/dist-packages/softwareproperties/ppa.py" file, line 386, in add_key
returns apsk.add_ppa_signing_key ()
"/Usr/lib/python3/dist-packages/softwareproperties/ppa.py" file, line 273, in add_ppa_signing_key
cleaning (tmp_keyring_dir)
"/Usr/lib/python3/dist-packages/softwareproperties/ppa.py" file, line 234, being cleaned
shutil.rmtree (tmp_keyring_dir)
"/Usr/lib/python3.5/shutil.py" file, line 480, in rmtree
_rmtree_safe_fd (fd, path, onerror)
"/Usr/lib/python3.5/shutil.py" file, line 438, in _rmtree_safe_fd
onerror (os.unlink, full name, sys.exc_info ())
"/Usr/lib/python3.5/shutil.py" file, line 436, in _rmtree_safe_fd
os.unlink (name, dir_fd = topfd)
FileNotFoundError: [Errno 2] No such file or directory: & # 39; S.gpg-agent.extra & # 39;
groot @ vps149861: /etc/apt # sudo apt-get update
Hit: 1 http://security.debian.org stretch / InRelease updates
Ign: 2 http://deb.debian.org/debian stretch InRelease
Hit: 3 http://deb.debian.org/debian stretch-updates InRelease
Hit: 4 http://deb.debian.org/debian stretch-backports InRelease
Hit: 5 http://deb.debian.org/debian Stretch Release
Hit: 6 http://mirror.aarnet.edu.au/pub/MariaDB/repo/10.2/debian stretch InRelease
Hit: 7 https://download.docker.com/linux/debian stretch InRelease
Ign: 8 http://ppa.launchpad.net/ondrej/nginx/ubuntu disco InRelease
Hit: 10 https://apt.blobfolio.com/debian stretch InRelease
Get: 11 http://ppa.launchpad.net/ondrej/php/ubuntu disco InRelease [20.8 kB]
Ign: 11 http://ppa.launchpad.net/ondrej/php/ubuntu disco InRelease
Ign: 12 http://ppa.launchpad.net/ondrej/nginx/ubuntu disco Release
Get: 13 http://ppa.launchpad.net/ondrej/php/ubuntu disco / main amd64 Packages [30.6 kB]
Get: 14 http://ppa.launchpad.net/ondrej/php/ubuntu disco / main Translation-en [11.5 kB]
Ign: 15 http://ppa.launchpad.net/ondrej/nginx/ubuntu disco / main amd64 Packages
Ign: 16 http://ppa.launchpad.net/ondrej/nginx/ubuntu disco / main all packages
Ign: 17 http://ppa.launchpad.net/ondrej/nginx/ubuntu disco / main Translation-en
Ign: 18 http://ppa.launchpad.net/ondrej/nginx/ubuntu disco / main Translation-en_US
Ign: 15 http://ppa.launchpad.net/ondrej/nginx/ubuntu disco / main amd64 Packages
Ign: 16 http://ppa.launchpad.net/ondrej/nginx/ubuntu disco / main all packages
Ign: 17 http://ppa.launchpad.net/ondrej/nginx/ubuntu disco / main Translation-en
Ign: 18 http://ppa.launchpad.net/ondrej/nginx/ubuntu disco / main Translation-en_US
Ign: 15 http://ppa.launchpad.net/ondrej/nginx/ubuntu disco / main amd64 Packages
Ign: 16 http://ppa.launchpad.net/ondrej/nginx/ubuntu disco / main all packages
Ign: 17 http://ppa.launchpad.net/ondrej/nginx/ubuntu disco / main Translation-en
Ign: 18 http://ppa.launchpad.net/ondrej/nginx/ubuntu disco / main Translation-en_US
Ign: 15 http://ppa.launchpad.net/ondrej/nginx/ubuntu disco / main amd64 Packages
Ign: 16 http://ppa.launchpad.net/ondrej/nginx/ubuntu disco / main all packages
Ign: 17 http://ppa.launchpad.net/ondrej/nginx/ubuntu disco / main Translation-en
Ign: 18 http://ppa.launchpad.net/ondrej/nginx/ubuntu disco / main Translation-en_US
Ign: 15 http://ppa.launchpad.net/ondrej/nginx/ubuntu disco / main amd64 Packages
Ign: 16 http://ppa.launchpad.net/ondrej/nginx/ubuntu disco / main all packages
Ign: 17 http://ppa.launchpad.net/ondrej/nginx/ubuntu disco / main Translation-en
Ign: 18 http://ppa.launchpad.net/ondrej/nginx/ubuntu disco / main Translation-en_US
Err: 15 http://ppa.launchpad.net/ondrej/nginx/ubuntu disco / main amd64 Packages
404 not found
Ign: 16 http://ppa.launchpad.net/ondrej/nginx/ubuntu disco / main all packages
Ign: 17 http://ppa.launchpad.net/ondrej/nginx/ubuntu disco / main Translation-en
Ign: 18 http://ppa.launchpad.net/ondrej/nginx/ubuntu disco / main Translation-en_US
Recovered 62.9 KB in 16s (3,899 B / s)
Reading package lists ... Done
W: GPG error: http://ppa.launchpad.net/ondrej/php/ubuntu disco InRelease: The following signatures could not be verified because the public key is not available: NO_PUBKEY 4F4EA0AAE5267A6C.
W: The Repository & # 39; http: //ppa.launchpad.net/ondrej/php/ubuntu disco InRelease & # 39; is not signed.
N: The data of such a repository can not be authenticated and are therefore potentially dangerous to use.
N: See the apt-secure (8) man page for details on creating repositories and configuring the user.
W: The Repository & # 39; http: //ppa.launchpad.net/ondrej/nginx/ubuntu disco Release & # 39; There is no release file.
N: The data of such a repository can not be authenticated and are therefore potentially dangerous to use.
N: See the apt-secure (8) man page for details on creating repositories and configuring the user.
E: Can not Extract http://ppa.launchpad.net/ondrej/nginx/ubuntu/dists/disco/main/binary-amd64/Packages 404 not found
E: Failed to download some index files. They were ignored or the old ones used instead.

I realize that the important bit is probably NO_PUBKEY 4F4EA0AAE5267A6C but what should I type to solve this problem so that an update of apt-get works?