Unable to upgrade from 2.2.6 to 2.3 via dialer

I have a own Magento 2.2.6 with sample data that I have installed using dial.

I'm trying to update it to Magento 2.3 in order to follow the steps outlined here by the Magento team.

After running composer's update I receive the following:

Loading composer repositories with package information
Update dependencies (including require-dev)
Your requirements could not be resolved into a set of installable packages.

Problem 1
- magento / module-wishlist-sample-data 100.2.0 requires magento / module-wishlist 101.0. * -> satisfiable by magento / wishlist module[101.0.4, 101.0.0, 101.0.1, 101.0.2, 101.0.3, 101.0.5].
- magento / module-wishlist-sample-data 100.2.0 requires magento / module-wishlist 101.0. * -> satisfiable by magento / wishlist module[101.0.4, 101.0.0, 101.0.1, 101.0.2, 101.0.3, 101.0.5].
- Can only install one of the following software: magento / module-wishlist[101.1.0, 101.0.4].
- Can only install one of the following software: magento / module-wishlist[101.1.0, 101.0.0].
- Can only install one of the following software: magento / module-wishlist[101.1.0, 101.0.1].
- Can only install one of the following software: magento / module-wishlist[101.1.0, 101.0.2].
- Can only install one of the following software: magento / module-wishlist[101.1.0, 101.0.3].
- Can only install one of the following software: magento / module-wishlist[101.1.0, 101.0.4].
- Can only install one of the following software: magento / module-wishlist[101.1.0, 101.0.5].
- magento / product-community-edition 2.3.0 requires magento / module-wishlist 101.1.0 -> satisfiable by magento / wishlist[101.1.0].
- Installation request for magento / product-community-edition 2.3.0 -> satisfiable by magento / product-community-edition[2.3.0].
- Installation request for magento / module-wishlist-sample-data 100.2. * -> satisfiable by magento / module-wishlist-sample-data[100.2.0].