variáveis – Lógica de programação (Portugol) (VisualG). Como essa variável (MA) consegue me mostrar o nome exato do aluno que obteve a maior nota?

O programa está funcionando perfeitamente. A minha dúvida é somente sobre esse algoritmo, não consigo entender como essa variável (MA) consegue me mostrar a maior nota apenas com a atribuição MA <- A. Se alguém conseguir me esclarecer essa questão eu agradeço.

Algoritmo "ContadorMaiorNota"

Var

   Q, contador: Inteiro

   N, MAIOR: Real

   A, MA: Caractere

Inicio

   contador <- 1

   Escreval("------------------------")

   Escreval(" ESCOLA ESTUDIOSOS ")

   Escreval("------------------------")

   Escreval("Quanto alunos tem na turma?")

   Leia(Q)

   Enquanto (contador <= Q) faca

      Escreval("Aluno ", contador)

      Escreval("Nome do aluno: ")

      Leia(A)

      Escreval("Nota do ", A,":")

      Leia(N)

      contador <- contador +1

      Se (N > MAIOR) entao

         MAIOR <- N

         MA <- A

      FimSe

   FimEnquanto

   Escreval("O maior aproveitamento foi o de ",MA," com a nota", MAIOR)

FimAlgoritmo