Which version of python is required to install electrum-ltc and electrum-dash in the amazon linux instance?


I'm trying to install different portfolios on my amazon linux ec2 instance. I already have an electrum-btc working.

[ec2-user@ip-xxx-xx-xx-xxx dash-electrum]$ python --version
Python 2.7.13
[ec2-user@ip-xxx-xx-xx-xxx dash-electrum]$ python3 --version
Python 3.4.8
[ec2-user@ip-xxx-xx-xx-xxx dash-electrum]$ uname -a
Linux ip-xxx-xx-xx-xxx 4.9.85-38.58.amzn1.x86_64 # 1 SMP Wed Mar 14 01:17:26 UTC 2018 x86 x64 x86_64 x86_64 GNU / Linux

But, when I am installing other clones for the litecoin command and pip dashcoin install, the command fails.

sudo which pip3 to install Electrum-DASH-2.9.4.tar.gz

        Running the installation of setup.py for hidapi ... error
Full output of the / usr / bin / python3 command -u -c "import setuptools, tokenize; __ file __ = / tmp / pip-install-y3d9_mm3 / hidapi / setup.py & # 39 ;; f = getattr (tokenize, & quot; open & quot;) (__ file __); code = f.read (). replace (& # 39;  r  n, & # 39;  n & # 39;  n ;); f.close (); exec (compile (code, __file__, exec)) "install - -record /tmp/pip-record-ffxgn444/install-record.txt --single- externally-managed-compile version:
currently being installed
running
running build_ext
cythoning hid.pyx to hid.c
building & # 39; hidden & # 39; extension
create the construction
build build / temp.linux-x86_64-3.4
build build / temp.linux-x86_64-3.4 / hidapi
build creation / temp.linux-x86_64-3.4 / hidapi / libusb
gcc -pthread -Wno-used-result -DDYNAMIC_ANNOTATIONS_ENABLED = 1 -DNDEBUG -O2 -g -pipe -Wall -Wp, -D_FORTIFY_SOURCE = 2 -fexceptions -fstack-protector-param = ssp-buffer-size = 4 -m64 -mtune = generic -D_GNU_SOURCE -fPIC -fwrapv -fPIC -Ihidapi / hidapi -I / usr / include / libusb-1.0 -I / usr / include / python3.4m -c hid.c -o build / temp.linux-x86_64- 3 , 4 / hid.o
gcc -pthread -Wno-used-result -DDYNAMIC_ANNOTATIONS_ENABLED = 1 -DNDEBUG -O2 -g -pipe -Wall -Wp, -D_FORTIFY_SOURCE = 2 -fexceptions -fstack-protector-param = ssp-buffer-size = 4 -m64 -mtune = generic -D_GNU_SOURCE -fPIC -fwrapv -fPIC -Ihidapi / hidapi -I / usr / include / libusb-1.0 -I / usr / include / python3.4m -c hidapi / libusb / hid.c -o build / temp. linux-x86_64-3.4 / hidapi / libusb / hid.o
hidapi / libusb / hid.c: 26: 0: warning: "_GNU_SOURCE" redefined
#define _GNU_SOURCE / * needed for wcsdup () before glibc 2.10 * /

: 0: 0: note: this is the location of the previous definition
hidapi / libusb / hid.c: 47: 10: fatal error: libusb.h: no file or directory of this type
#understand 
          ^ ~~~~~~~~~~
compilation completed.
error: the command & # 39; gcc & # 39; failed with exit status 1

--------------------------------------------
"/ Usr / bin / python3 -u -c" command import setuptools, tokenize; __ file __ = & # 39; / tmp / pip-install-y3d9_mm3 / hidapi / setup.py & # 39 ;; f = getattr (tokenize, & quot; open & # 39 ;, open) (__file __); code = f.read (). replace ('#'; & # 39;  n); f.close (); exec (compile (code, __file__, exec)) install --record /tmp/pip-record-ffxgn444/install-record.txt --single-version-externally-managed-administrally - compile "failed with error code 1 in / tmp / pip-install-y3d9_mm3 / hidapi /

What am I doing wrong? Can I install a single Electrum portfolio on a server?