Why check the PHP settings and check the component dependency by displaying an error when upgrading Magento 2.3?

I will upgrade Magento from version 2.1.12 to version 2.3 using the Web Configuration Wizard. During this process, it displays two errors Checking PHP Settings and Verifying Component Dependency. We have already set memory_limit = 2GB in php / php.ini, but that indicates the same error. Guide me please.