why do they still support all those different versions of postgresql?

i selected postgresql as my main sql dialect and db for studying.

I checked the official website – it’s confusing why they have so many versions?

Can someone explain?